meridian-shaft Jump to content
Forums

Disque invisible sous Linux


Recommended Posts

Bonjour

Soit un PC Acer Aspire A317-52

Processeur Intel I5-1035G1

Mémoire 8 Go

2 disques

 1 "Disque" SSD NVME de 128 Go SAMSUNG MZVLQ128HBHQ

1 Disque 1 To  WDC WD10SPZX-21Z10T0

Les 2 disques son t invisible sous Linux,

Après modification dans le Bios de la Gestion Optane en Ahci (dans le Bios onglet Main, effectuer un Ctr S pour faire apparaître la ligne adéquat et pouvoir la modifier)

Le disque SSD apparait bien sous Linux mais pas le disque physique de 1 To

Quelqu'un a un e idée pour résoudre ce problème ???

Merci

Link to comment

A la lecture du résultat, le second disque n'est pas visible, seul le SSD Nvme et le lecteur du DVD sont visibles ainsi que ma clef USB qui me sert a charger PartedMagic (avec lequel je réalise les partitionnement nécessaires avant installation de Ubuntu ainsi que les images disque avant toute intervention.)

Link to comment

Bonjour,

Non je ne suis pas d'accord, ton deuxième disque est visible comme tu peux le constater

1604176934_Capturedcrandu2022-02-1016-57-05.png.d6482209352feb72ce9b4cf9f8994d14.png

En jaune il voit un total de 1.03 TiB (le total ) et comme tu peux le constater aussi en jaune tu as /dev/sdb qui représente ton DD

Ce qui est étrange, on dirait qu'il le voit comme un périphérique externe :hollande:

Edited by Tulburite
Link to comment

Euh, erreur de ma part, il i y 2 éléments connectés en USB, 1 disque de 1 To avec 1 partition principale SB1 et une partition étendue contenant 2 partitions SDB5 et SDB6 ainsi que ma clef de boot SDA1 de 4 Go

J'ai mal défini l'ensemble dans mon premier poste.

Et je vois bien l'ensemble des 4 éléments sous Windows mais sous Linux, le disque interne est absent (il ne contient, d'après Windows) que 1 partition

Link to comment

Euh, erreur de ma part, il i y 2 éléments connectés en USB, 1 disque de 1 To avec 1 partition principale SB1 et une partition étendue contenant 2 partitions SDB5 et SDB6 ainsi que ma clef de boot SDA1 de 4 Go

J'ai mal défini l'ensemble dans mon premier poste.

Et je vois bien l'ensemble des 4 éléments sous Windows mais sous Linux, le disque interne est absent (il ne contient, d'après Windows) que 1 partition

Link to comment

Ce qui serait intéressant de faire maintenant c'est d'enlever toutes les périphériques extérieures, de laisser que tes SSD/DD internes. De télécharger Ubuntu et de créer une clé bootable, de lancer le live USB et de regarder si Ubuntu voit ce DD soit avec gnome disque ou soit avec la commande sudo fdisl -l

  • J'aime 1
Link to comment

Bonjour,

Je m'excuse pour le délai de réponse mais j'ai du partir à l'autre bout du pays ... ce qui est étrange c'est comment Ubuntu voit les disques, normalement c'est du /dev/sda; /dev/sdb ou encore /dev/sbx etc. Chez toi le /dev/sda et /dev/sdb sont les périphériques externes ...

J'ai regardé chez moi sur un Lenovo ou j'ai un SSD qui est reconnu comme /dev/nvme0n1 (identique chez toi) mais mon second SSD est reconnu comme un /dev/sda et c'est ici qu'il y a le problème

359576394_Capturedcran_2022-02-12_16-34-44.thumb.png.c1c1569f82871f3770bb15720df724c1.png

Personnellement je pense qu'il faut piocher dans le bios de ta machine pour commencer et pour ça je vais taguer @Delta @zelandonii @Toto61 @Yves B. @calisto06 et @Firebird

Merci à vous tous pour apporter vos lumières à comment faire pour faire reconnaître ce disque à Ubuntu ou autres distributions

  • J'aime 1
Link to comment

Bonjour Tulburite

J'ai eut il y a peu pour un ami artisan un PC ACER-Nitro_NH.Q8.JE3F.005 beaucoup plus puissant que celui-ci.

Il était livré avec un SSD de 1 To, mais il disposait d'un second emplacement SSD et d'un emplacement pour un disque dur classique. Je l'ai équipé d'un second SSD de 500 Go dédié aux applications portable que je favorise (Libre office, Thunderbird, Firefox etc) et d'un disque dur classique de 2 To (pour ses datas pro car je pense que l'on peut récupérer les datas d'un disque mécanique mais cela me semble impossible d'un SSD)

Je n'ai pas rencontrer ce problème, les 2 SSD etait vue comme /dev/nvme0n1 et /dev/nvme0n2 et le disque dur comme /dev/sda

Nota : j'utilise PartedMagic pour créer et gérer les partitions et pour réaliser une image disque, après l'installation de Windows et des applications.

Merci pour vos efforts

Link to comment

Bonjour aldurpor

il y a 49 minutes, aldurpor a dit :

Je n'ai pas rencontrer ce problème, les 2 SSD etait vue comme /dev/nvme0n1 et /dev/nvme0n2

Oui parce que cet ordinateur avait deux port M2 et Ubuntu les as bien reconnu, ensuite cet ordinateur avait également un port SATA ou dessus était branché le DD (/dev/sda), en comparaison sur mon Lenovo j'ai un port M2 et un port SATA.

Sur ton ACER (je suppose que tu as celui-ci), tu as un port M2 et un port SATA donc normalement pas de problème pour Ubuntu normalement ...

J'ai également vu une chose étrange, tu as le sécure boot désactivé, bon ça ne devrait pas poser problème ... va savoir, je persiste quand même à regarder dans ton Bios/UEFI pour résoudre le problème.

Edited by Tulburite
Link to comment
il y a 12 minutes, Tulburite a dit :

J'ai également vu une chose étrange, tu as le sécure boot désactivé, bon ça ne devrait pas poser problème ... va savoir

hello,

je pense que c'est le mieux pour Linux et deux système d'exploitation sur un même pc d'avoir le secure boot désactivé.

 

  • J'aime 1
Link to comment

En fait ce que je voulais dire et en essayant de trouver une solution pour la reconnaissance de ce deuxième DD c'est que Secure boot est désactivé. Seulement Ubuntu gère très bien le fait que Secure boot soit activé à l'installation et ne va normalement pas empêché l'installation. Je pense pas que ça va faire quelques choses mais j'aimerai que aldurpor puisse installer sa distribution Linux

Edited by Tulburite
Link to comment

Salut, et merci pour le ping @Tulburite,

A première vue, une recherche sur Google indique qu'il y a pas mal de problème avec certains contrôleurs SATA non reconnus sur les série Aspire A315 / A316 d'Acer, donc peut être A317. Pas mal d'articles renvoient sur ce lien notamment : https://community.acer.com/en/discussion/589603/linux-live-usb-doesnt-detect-hdd-on-aspire-3-a315-56/

En gros, si le passage du contrôleur du mode Optane vers AHCI ne suffit pas à résoudre le soucis depuis un LiveUSB comme cela semble le cas, pour certains, il faut, après avoir booté sur un LiveUSB Linux, passer par une veille et en sortir pour parfois voir apparaître le disque SATA... Et ça reste aléatoire !

J'ai l'impression @aldurpor que tu n'as pas choisis le bon modèle pour Linux.

  • J'aime 1
  • Plusser (+1) 2
Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...