Jump to content
Site Communauté

Problème lors de l'utilisation de VM : Segmentation fault


someone

Recommended Posts

Bonjour tout le monde ! :c_doubtfully:

Je suis confronté à un problème assez embêtant lors de l'utilisation de VM avec mon PC Windows 10. Pour des besoins de développement, j'ai installé Vagrant et VirtualBox pour créer facilement des nouvelles VM. J'ai commencé par créer une VM basée sur le Vagrantfile suivant : https://bit.ly/2FxCvgj. Pour faire simple, il s'agit d'une VM Ubuntu Server 18.04 LTS avec quelques logiciels préinstallés.

La VM est créée sans problème par Vagrant et apparait bien dans l'interface de VirtualBox. Je peux m'y connecter en SSH sans soucis. Après avoir effectué quelques commandes, le problème apparait. Toutes les commandes que j'essaie de faire répondent "Segmentation fault".

Après quelques recherches, j'ai découvert qu'il s'agissait d'une erreur provenant d'un accès mémoire non autorisé. J'ai alors essayé de créer une nouvelle VM depuis Vagrant (mais utilisant une base différente), même problème. Notez également que je n'ai jamais réussi à faire fonctionner Hyper-V sur mon PC (les VM ne fonctionnaient également pas), alors que WSL2 fonctionne parfaitement. J'en conclus donc à un problème de virtualisation propre à mon ordinateur, et non au logiciel utilisé.

Voilà, j'espère que certains d'entre vous pourront me dépanner de cette situation. Et merci d'avance à ceux qui m'aideront :c_sunglasses:

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...