meridian-shaft Jump to content
Forums

Les fichiers .exe ne s'ouvrent pas


Recommended Posts

Bonjour, j'ai un très gros problème : absolument tous les fichiers .exe d'un pc sous Windows 7 que j'utilise souvent (ce n'est pas le mien d'autres personnes l'utilise aussi) ne s'ouvrent plus. C'est comme depuis que je l'ai allumé aujourd'hui, alors que hier, aucun soucis. J'ai vu que qu'en face de chaque fichier .exe, maintenant il y a marqué "1%" au lieu de "application", j'ai donc voulu essayer de résoudre ça avec regedit, sauf que regedit étant un .exe, impossible de l'ouvrir lui aussi... Je pense pas que ce soit un virus, mais plutôt quelqu'un qui a fait une mauvaise manipulation avant que j'utilise l'ordi.

J'aimerai savoir si il y a un moyen de résoudre ça sans avoir à restaurer le système...

Link to comment
  • 2 weeks later...

Bonjour,

Sous Windows 10, j'ai eu exactement le même problème : en cliquant sur n'importe quel fichier .exe, il ne se passe rien.

J'ai trouvé la solution pour mon cas : j'avais changé le répertoire par défaut de Program Files de C à D dans le registre, par commodité (ayant mon système sur C et mes données sur D).

C'est certainement la cause du problème, puisque, sans rien changer d'autre, en repassant à C mes .exe s'ouvrent à nouveau correctement. Voilà comment faire :

- D'abord passer en mode sans échec pour ouvrir Regedit, qui est aussi un .exe...

Appuyer sur Maj + cliquer sur Redémarrer puis Diagnostic -> Options avancées -> Paramètres de démarrage -> Redémarrer -> Choisir 5 au redémarrage.

- Ouvrir Regedit en mode administrateur puis aller dans HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows -> sélectionner CurrentVersion, puis cliquer sur "ProgramFilesDir" et remettre le chemin par défaut "C:\Program Files".

- Cliquer aussi sur "ProgramFilesDir (x86)" et remettre le chemin par défaut "C:\Program Files (x86)".

- Puis quitter Regedit et redémarrer.

Dès que j'ai fait cette modif (et uniquement cette modif), j'ai à nouveau pu ouvrir mes .exe en mode normal.

En espérant avoir pu vous aider !

Link to comment

Yep,
 

Le undefined à 23:13, Mo Ja a dit :

J'ai trouvé la solution pour mon cas : j'avais changé le répertoire par défaut de Program Files de C à D dans le registre, par commodité (ayant mon système sur C et mes données sur D).

Très mauvaise idée ça ! :P
On ne délocalise jamais le dossier Program Files (x86) !

@Mo Ja J'ai rédigé un tutoriel pour bien cloisonner sont PC.Il pourrait t'intéresser au vu de ce qu tu racontes ;)


@Lunai

Si la restauration du système ne fonctionne pas, oriente toi vers une ré-initialisation de Windows (sans pertes des données) ;)

Passe un bon week-end

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...