meridian-shaft Jump to content
Forums

Souci menu démarrer et applications


Solved

Recommended Posts

Bonjour,

J'ai rencontré récemment un gros problème sur mon ordinateur portable ASUS en le démarrant ce matin : quand j'ouvrais le menu démarrer, toute la barre latérale avec les applications qui s'affichent n'étaient plus là, je n'avais plus accès à rien. Dès lors pour accéder à l'application du windows store "courrier" pour les e-mails etc je l'ai tapé dans la rechercher Cortana, et au lieu d'ouvrir l'application ça m'a dirigé vers le windows store. Un message s'affichait du style "installez sur votre disque interne blabla" (sans rien pour installer) et quelques secondes plus tard ça mettait "lancer". Très bien, je lance, l'application s'ouvre normalement, mais AUCUN icone ne s'affichait dans la barre des tâches, et évidemment en réduisant la fenêtre, page disparue... obligée de reproduire le processus précédemment dit. En fait toutes les applications relatives à windows peuvent s'ouvrir mais ne s'affichent plus ni dans la barre des tâches ni dans le menu démarrer donc c'est vraiment embêtant.

Pour y remédier j'ai consulté une page du crabe info justement avec de multiples solutions, j'ai tout essayé (sauf remise à zéro totale parce que, ayant des logiciels lourds et longs à installer type Adobe, je ne peux pas me permettre de passer 3000 ans à tout réinstaller). Même une restauration à une date antérieure a échouée pour je ne sais quelle raison.

Parmi les solutions essayées j'ai crée un deuxième compte admin donc une deuxième session. Je m'y rends : aucun problème ! Donc ça vient de ma session principale administratrice.

Qu'est-ce que je peux faire pour remédier à ça ? Sachant que je suis vraiment une quiche en paramètres etc... ce problème est vraiment handicapant et m'empêche d'avoir recours à mes applications principales.

 

Merci d'avance!

Link to comment

Salut !

Qu'as-tu essayé ? Ces manipulations ? -> https://lecrabeinfo.net/probleme-impossible-utiliser-barre-des-taches-et-menu-demarrer-bloques-sur-windows-10.html

Si tu as tout essayé, comme tu dis, alors je ne vois que la solution d'un déménagement de tous les documents et fichiers de paramètres depuis le compte en panne vers le nouveau compte fonctionnel.

1. Copier le profil

Depuis ton nouveau compte fonctionnel, affiches les dossiers cachés : dans l'explorateur de fichiers, cliques sur l'onglet "Affichage" et dans "Afficher/masquer" coches la case "Éléments masqués".

Révélation

win8.jpg

common_3580_1522-294843.png

Ensuite, rends-toi dans C:\Users\nom-du-compte-en-panne et copies tes documents, bien-sûr, mais également le dossier caché AppData dans ce profil.
Colles le tout dans un dossier à part, dans C:\backup par exemple (ne remplaces rien pour l'instant).

2. Coller et remplacer depuis un autre compte admin

Ensuite, actives le compte super-admin :

https://lecrabeinfo.net/comment-activer-le-compte-administrateur-cache-sur-windows-10-8-ou-7.html

Depuis celui-ci, retournes copier ta copie de sauvegarde (dans C:\backup dans mon exemple), et vas dans C:\Users\nom-du-nouveau-compte-fonctionnel pour remplacer les dossiers.

Puis tu pourras re-cacher le compte super-admin.

3. Renommer les comptes

Une fois la manip réalisée, fais la combinaison de touches +R tapes lusrmgr.msc et valides. Si tu obtiens un message d'erreur, refais la manipulation en tapant plutôt :
control userpasswords2

On va permuter les noms de compte : Double-cliques sur le compte en panne et renommes-le. Puis double-cliques sur le compte fonctionnel et donnes-lui le premier nom qu'avait le compte en panne.

Après, tu devras peut-être ré-installer certains logiciels installés uniquement sur ton premier compte. Et là normalement, tout devrait être OK.

  • Plusser (+1) 1
Link to comment

Bonjour @Ravenna

Il me semble que les manipulations décrites par @Le PoissonClownsont suffisamment détaillées (un vrai tuto), et si j'ai bien compris il faut opérer

 1 Dans ton nouveau compte Administrateur comme ceci :

Le 25/03/2017 à 19:39, Le PoissonClown a dit :

Ensuite, rends-toi dans C:\Users\nom-du-compte-en-panne et copies tes documents, bien-sûr, mais également le dossier caché AppData dans ce profil.
Colles le tout dans un dossier à part, dans C:\backup par exemple (ne remplaces rien pour l'instant).

2 Dans le compte super Administrateur comme ceci :

Le 25/03/2017 à 19:39, Le PoissonClown a dit :

Ensuite, actives le compte super-admin :

https://lecrabeinfo.net/comment-activer-le-compte-administrateur-cache-sur-windows-10-8-ou-7.html

Depuis celui-ci, retournes copier ta copie de sauvegarde (dans C:\backup dans mon exemple), et vas dans C:\Users\nom-du-nouveau-compte-fonctionnel pour remplacer les dossiers.

3 Dans ton nouveau compte Administrateur comme ceci :

Le 25/03/2017 à 19:39, Le PoissonClown a dit :

Une fois la manip réalisée, fais la combinaison de touches +R tapes lusrmgr.msc et valides. Si tu obtiens un message d'erreur, refais la manipulation en tapant plutôt :
control userpasswords2

On va permuter les noms de compte : Double-cliques sur le compte en panne et renommes-le. Puis double-cliques sur le compte fonctionnel et donnes-lui le premier nom qu'avait le compte en panne.

Attend son retour @Le PoissonClown pour plus de précisons et de certitudes

Cordialement
Kristobal

 

Link to comment

Alors, merci de vos réponses

J'ai effectué toutes les tâches à réaliser pour "cloner" mon compte sur la nouvelle session. Tout a correctement été migré, compte identique.

Cependant, le problème a migré aussi ! Alors qu'auparavant sur cette session "neuve" non défectueuse il n'y avait pas le problème... Du coup ça n'a servi à rien :(
Sous-entendu le problème vient d'un fichier ?

Merci d'avance

Link to comment

Salut !

Oui, le souci vient certainement d'un fichier de paramètres Windows. :(

Les fichiers de config du menu Démarrer se trouvent dans le dossier AppData\Local\TileDataLayer\Database de chaque compte.
Le hic, c'est que, pour pouvoir les copier ou les coller/remplacer, il faut le faire depuis un autre compte (impossible sur le compte actif, car ils sont en cours d'utilisation). D'où l'ouverture du compte super-admin.

Voici ce que j'essayerais :

0. Pour que le tuto soit plus clair, appelons "Joker" le compte en panne sur lequel sont présent les documents.

1. Créer (encore) un nouveau compte admin. Pour que le tuto soit plus clair, appelons-le "Batman".

2. Activer le compte super-admin et lui ouvrir une session.

3. Depuis cette session super-admin, aller dans C:\Users\Joker\AppData\Local\TileDataLayer\Database
Copier le fichier vedatamodel.edb (c'est lui qui restitue l'organisation des tuiles).

4. Aller ensuite dans C:\Users\Batman\AppData\Local\TileDataLayer
Coller temporairement le fichier vedatamodel.edb
Puis faire une copie de sauvegarde (au cas où) du dossier Database tout propre ("Database-sauvegarde" par exemple).

5. Dans le dossier Database tout propre, remplacer le fichier C:\Users\Batman\AppData\Local\TileDataLayer\Database\vedatamodel.edb par notre fichier copié précédemment (qui vient du compte du Joker).

6. Copier le dossier Database tout-propre-mais-bidouillé, et remplacer le dossier du vilain C:\Users\Joker\AppData\Local\TileDataLayer\Database

Ceci permettra de remplacer tous les fichiers système du menu Démarrer en panne sans toucher au fichier d'organisation des tuiles… En espérant que ce n'est pas lui qui fiche la pagaille.
Si c'est malheureusement le cas, il suffira de remplacer le dossier C:\Users\Joker\AppData\Local\TileDataLayer\Database par la sauvegarde présente dans C:\Users\Batman\AppData\Local\TileDataLayer.

… On va y arriver. Courage ! :fist-pump-baby:

Edited by Le PoissonClown
Rectification plus claire
  • Plusser (+1) 1
Link to comment

ah d'accord! je ne savais pas qu'il y avait un compte admin caché! merci beaucoup j'essaie donc


Donc je suis bloquée à l'étape 4. Quand je veux coller le fichier vetadamodel.edb dans tiledatalayer de batman ça m'affiche une fenêtre "cette action ne peut pas être réalisée car le fichier est ouvert dans service state repository  (staterepository)"... cest quoi ce blabla ? :( 

Link to comment
Il y a 4 heures, Ravenna a dit :

Donc je suis bloquée à l'étape 4. Quand je veux coller le fichier vetadamodel.edb dans tiledatalayer de batman ça m'affiche une fenêtre "cette action ne peut pas être réalisée car le fichier est ouvert dans service state repository  (staterepository)"... cest quoi ce blabla ? :( 

Ah ! J'ai oublié de préciser qu'il faut fermer les sessions des comptes sur lesquels on manipule ces fichiers. Sinon, le système considère qu'ils sont en cours d'utilisation.

Désolé.

Link to comment
il y a 25 minutes, Ravenna a dit :

Pareil, j'ai supprimé le dossier comme il fallait et toujours pareil... Je ne peux même plus accéder aux applications :(:(:(

En voilà un bug infernal ! :c_tongue:

Le dossier Database supprimé a-t-il été re-généré ? Si ce n'est pas le cas il faudra redémarrer le PC.

Sorti de ça, je ne sais pas trop quoi faire… Tu as déplacé le fichier NTUSER.DAT avec tes documents ?

  • Plusser (+1) 1
Link to comment

Ah zut. Le souci ne vient pas des fichiers du menu Démarrer alors. :c_tongue:

Le fichier ntuser.dat ne doit pas être supprimé. Il contient la partie du registre qui est associée au compte utilisateur. Je me demandais : si tu l'as bien transféré, il se peut que ce soit lui qui contient les erreurs qui sont à l'origine du bug.

Personnellement, sous Windows 8.1, j'avais un bug qui ouvrait plusieurs fenêtres à chaque fois que je double-cliquais sur un dossier dans mes documents. Il a fallu que je migre tout sur un autre compte administrateur, excepté le fichier ntuser.dat. Rien d'autre ne pouvait résoudre le souci.

C'est une piste à creuser.

Link to comment
Le 29/03/2017 à 22:35, Le PoissonClown a dit :

Ah zut. Le souci ne vient pas des fichiers du menu Démarrer alors. :c_tongue:

Le fichier ntuser.dat ne doit pas être supprimé. Il contient la partie du registre qui est associée au compte utilisateur. Je me demandais : si tu l'as bien transféré, il se peut que ce soit lui qui contient les erreurs qui sont à l'origine du bug.

Personnellement, sous Windows 8.1, j'avais un bug qui ouvrait plusieurs fenêtres à chaque fois que je double-cliquais sur un dossier dans mes documents. Il a fallu que je migre tout sur un autre compte administrateur, excepté le fichier ntuser.dat. Rien d'autre ne pouvait résoudre le souci.

C'est une piste à creuser.

Le fichier ntuser.dat est toujours bien présent. S'il est à l'origine du problème, je dois réessayer à nouveau une "migration" de tous mes fichiers vers "Batman", sans migrer ce fichier ?

Link to comment
  • 2 weeks later...
Le 01/04/2017 à 19:33, Le PoissonClown a dit :

Oui, c'est à tenter, je pense.
Après ça, si ça recommence, je donne ma langue au chat. :/

 

Le 01/04/2017 à 20:07, Yves B. a dit :

Salut @Ravenna,

Est-ce que tu as essayé la réparation sans perte de données, la méthode #2 ?

Tiens nous informé

A+:c_wink:

Bonjour,

Je reviens tardivement l'histoire de vous tenir au courant de mon avancée.

J'ai réussi à résoudre le problème en fouinant et en bricolant un peu à mes heures perdues. Les applications qui ne s'affichaient plus (invisibles) dans la barre des tâches, je les ai désinstallées & réinstallées et miracle, elles sont réapparues ! Pour ce qui est du volet démarrer, j'ai réussi à le "déplier" et à remettre manuellement les applications que je voulais avoir à portée de main. Même si c'est peut-être temporaire ma foi ça a marché! Super Windows et ses bugs... Merci quand même pour vos réponses! :):)

Edited by Ravenna
Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...