Jump to content
Site Communauté

captvty problème framework 4.0


Recommended Posts

bonjour ,

J'ai un problème pour installer le logiciel Captvty. lors de l'installation on me dit que je dois installer net framework 4.0 et quand je veux l'installer, on me dit que l'ordinateur a déjà une version plus récente et que ce n'est pas nécessaire. J'ai windows 10 .

Link to comment

Le souci se présente également sur la version extraite de l'archive Zip ?

image.png

Parce que si c'est le cas, je ne vois qu'un problème de Net Framework Runtime. Peut-être sont-ils installés en version 64b alors que CapTVty est en 32b ? Mais normalement la dernière version est compatible pour les deux architectures. Étrange ce problème !

Link to comment

non je n'ai pas cette cle dans le registre

 

j'ai la version v.2 et v.3

J'ai déjà essayé la version 4 mais a l'installation, on me dit que j'ai une version plus récente et que je n'en ai pas besoin

Link to comment

D'accord, donc le problème est bien là puisque vous êtes sensé l'avoir !
À quoi sert ce Repair Tool de carnaval, je me le demande !? :jesus-mdr2:

Dans cette clé HKEY_CLASSES_ROOT\Installer\Products\
Avez-vous un package d'installation qui comporte une valeur ProductName contenant un Microsoft .NET Runtime comme ici ou rien du tout ?

image.png

Link to comment

j'ai les mêmes versions 3.5 et 4.8 sauf que pour le logiciel Captvty, on demande le net framework 4.0 et quand je veux l'installer, la réponse me dit que j'ai déjà une version ultérieure et donc que je n'ai pas a l'installer. Et quand je veux réinstaller Captvty on me redit la même chose. Je tourne en rond dans tout ca!

Link to comment

Bon. Alors il y a un souci : le .Net Framework 4.8 est listé dans les fonctionnalités alors que la clé de registre liée à son installation n'existe pas sur le système :

Il y a 22 heures, Le PoissonClown a dit :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full

Je serais d'avis de vérifier son intégrité :

https://lecrabeinfo.net/sfc-exe-reparer-windows-avec-verificateur-des-fichiers-systeme.html

Link to comment

désolé, j'ai déjà fait tout ca, en lisant sur votre site, mais ca n'a rien donné.Je vais laisser tomber car ca fait déjà un moment que je galère sur ca et je commence a en avoir assez . A un moment, il faut lâcher prise. Merci beaucoup de votre aide et de vos conseils.

  • J'aime 1
Link to comment

OK. Alors si le système est intègre, j'ai une dernière piste :

  1. Désinstaller les derniers .Net Framework jusqu'au 4 (en partant du plus récent),
  2. Nettoyer les entrées inutiles du registre (après sauvegarde, bien entendu) via un outil comme CCleaner par exemple.
  3. Réinstaller la dernière version.

Après, personnellement j'abandonnerais. Mais je comprends totalement l'exaspération, il n'y a pas à être désolé. :c_wink:

Link to comment

Je passe par là car j'ai vu Captvty affiché :p je l'utilisais tellement quand il fonctionnait avec M6 ^_^ Perso, je n'ai pas de .NET Framework 4 et je suis sur Windows 11.

Ce que je te conseil :

- faire impérativement tes mises à jour Windows, ça peut paraitre bête, mais certains ne les font pas, après ils ont des soucis, avec WU ça règle beaucoup de soucis

- ensuite dans la liste des programmes, supprime tout ce qui est lié à .NET et Microsoft Visual tel que : Microsoft .NET Framework, Microsoft .NET Runtime, Microsoft Visual C++ 2010 à 2022 comme ici :

Capturedcran2024-06-14044445.thumb.png.dc7fbeab580be9d7685ec0f70f2ddd72.png

Ensuite, tu redémarres, dès que tout est propre et bien ranger.

On va commencer à télécharger (pour Windows 7 / 10 / 11 64 bit) :

- Microsoft Visual C++ Redistributable 14.40.33810.0 (dernière version en date du 14 juin 2024)
- .NET Desktop Runtime 8.0.6
- .NET Runtime 8.0.6

On redémarre et on essaie.

Personnellement j'utilise ces 3 applis provenant de chez Microsoft et pour le moment, aucun logiciel ne fonctionne pas, idem pour Captvty 2 / 3.

En espérant avoir aidé !

Capturedcran2024-06-14045238.thumb.png.3fb4ef8b10654171ebbae4e7ccddea41.png

  • Plusser (+1) 1
Link to comment

Merci pour les informations. J'ai essayé ce que vous m'avez suggéré intégralement, mais malheureusement, ca ne fonctionne toujours pas. Lorsque que j'essaie de télécharger Captvty, on me dit d'installer net framework 4.0 et encore une fois, lorsque je veux l'installer on me dit que j'ai déjà une version ultérieure et donc que je n'ai pas a l'installer. J'aurais vraiment aimé que vos suggestions fonctionnent. C'est bien dommage. Merci quand même.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...