meridian-shaft Jump to content
Forums

Installation pilote NVIDIA sur Debian 11.3


Go to solution Solved by Tulburite,

Recommended Posts

Bonjour à toutes et à tous,

J'essaye d'installer le pilote de ma carte graphique Nvidia Quadro P400 sur un OS Debian 11.3, en suivant les instructions de l'article "Installer le pilote propriétaire NVIDIA sur Debian Linux"

Après avoir réalisé la procédure décrite dans l'article, la commande "nvidia-detect" m'indique d'installer le paquet "nvidia-legacy-390xx-driver" comme si je n'avais rien installé. Je retente une seconde fois : j'exécute les commandes "apt install linux-headers-amd64" puis "apt install nvidia-legacy-390xx-driver".

A ce moment là j'ai le message "nvidia-legacy-390xx-driver est déjà la version la plus récente (390.144-1)". Je reboot et là retour à la case départ, la commande "nvidia-detect" m'indique d'installer le paquet "nvidia-legacy-390xx-driver"...

Du coup, j'ai décidé de désinstaller le pilote avec "apt purge nvidia." comme indiqué dans l'article mais j'ai eu le retour suivant :
E: Impossible de trouver le paquet nvidia.
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « nvidia. »

Comme ça n'a pas eu l'air de marcher, j'ai tenté "apt purge --autoremove '*nvidia*'" qui a supprimé 17 paquet dont "nvidia-legacy-390xx-driver" puis "apt-get update" et "apt-get upgrade".

Je repars de 0 avec "apt install nvidia-legacy-390xx-driver", le pilote s'installe, je redémarre avec "systemctl reboot". Et ... toujours rien, le pilote n'est pas détecté alors même qu'il est installé.

J'ai également essayé "apt install nvidia-legacy-390xx-driver --reinstall" mais sans succès.

Est-ce que quelqu'un aurait une piste de résolution ? Quelque chose que j'aurais zappé ?

Merci d'avance pour vos réponses,

Link to comment

Bonjour @QuentinPlsn,

C'est vrai que Debian des fois est un peu capricieux pour installer un pilote graphique ... néanmoins on va essayer quelques choses.

Pour commencer il faut t'assurer que tes sources contrib et non-free soient bien activées, pour ça tu vas dans softwares et updates pour en être certain.

191921384_Capturedcrandu2022-07-0816-39-33.png.18344c4059964bbe15c13377eb35ef1d.png

De plus par rapport à ma machine virtuelle ce n'est même pas certain que ta CG soit prise en compte

Ensuite tu vas installer synaptic avec la commande suivante

apt install synaptic

Une fois synaptic installé, recherche le driver Nvidia 390, une fois le cette opération effectuée tu coches nvidia-legacy 390xx driver, ceci va installer également toutes les dépendances

219200747_Capturedcrandu2022-07-0816-51-42.thumb.png.13c3ce4903e2b17b0a1175bb0b0e9002.png

Ensuite tu reviens ici pour nous donner des nouvelles

Link to comment

Bonjour @Tulburite,

Merci pour ta réponse, je viens d'essayer ce que tu propose.

D'après les infos affichées dans Software & Updates, les sources contrib et non-free sont bien activées.

1806981293_Capturedcrande2022-07-1410-11-38.png.bbc8c2b243cbf88b030c3b3b64c06591.png

Synaptic était déjà installé sur ma machine, et le paquet nvidia-legacy 390xx driver avec toutes les dépendances associées également. J'ai donc coché les paquets pour mise à jour.

1801754815_Capturedcrande2022-07-1410-13-46.thumb.png.6055e760687c10956d1996fa234a8073.png

La mise à jour se fait sans encombre, en fait il ne se passe pas grand chose comme on peut voir dans le résumé : "0 B seront téléchargés."

77508142_Capturedcrande2022-07-1410-14-14.png.d7eaf3ef2420a692d3f5da1539dc1334.png

Une fois l'opération terminée, retour à la case départ, la commande nvidia-smi ne donne rien et la commande nvidia-detect me donne une liste de driver à installer.

1275629416_Capturedcrande2022-07-1410-17-19.png.58ea31c3b27d3f3a1a23c48f60259fc1.png

 

Link to comment

Bonjour,

Bon c'est peut-être pas le bon driver que tu essayes d'installer, l'article fait référence à une ancienne distribution de Debian et peut-être que le driver 390xx n'est plus supporté par le nouveau noyau.

Quand je regarde ta capture d'écran tu devrais avoir le même driver que moi (GP107GL)

Que retourne la commande

uname -r

Link to comment
  • Solution

Ok, pourtant le driver 390xxx devrait fonctionner normalement ... c'est pas grave nous allons procéder à la purge de ce driver et installer le 470xxx. Soit par le terminal ou par synaptic purge moi tout ce que tu as en ce qui concerne le driver 390xxx, une fois ceci fait on va installer le nouveau pilote. Bon je dois m'absenter un moment je reviens après dans l'après-midi.

Link to comment

La purge du driver 390xx et l'installation du driver 470xx s'est passé sans encombres avec Synaptic. La commande nvidia-smi me retourne :

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.43.04    Driver Version: 515.43.04    CUDA Version: N/A      |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  Quadro P400         Off  | 00000000:2D:00.0 Off |                  N/A |
| 33%   44C    P0    N/A /  N/A |      0MiB /  2048MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

C'est plutôt bon signe, hormis le fait que la Quadro P400 est à l'état "Off" et qu'aucun processus n'est détecté. Je vais installer CUDA avec apt-get -y install cuda et voir ce que ça donne.

Link to comment

Après redémarrage, tout semble OK. Merci pour ton aide @Tulburite !

Fri Jul 15 11:51:20 2022       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.43.04    Driver Version: 515.43.04    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  Quadro P400         On   | 00000000:2D:00.0  On |                  N/A |
| 34%   43C    P5    N/A /  N/A |    235MiB /  2048MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      1334      G   /usr/lib/xorg/Xorg                104MiB |
|    0   N/A  N/A      1456      G   /usr/bin/gnome-shell               88MiB |
|    0   N/A  N/A      3140      G   ...290306194261172515,131072       39MiB |
+-----------------------------------------------------------------------------+

 

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...