meridian-shaft Jump to content
Forums

Installation Linux dans Virtualbox


Recommended Posts

Bonjour,

Peu importe le Linux que j'essaie d'installer dans Virtualbox (Ubuntu  ou Debian) cela ne fonctionne pas (toujours le même écran).

J'ai installé un Windows 8.1 et ça marche bien.

Si vous avez une idée, je vous remercie de votre aide.

VirtualBox_DEBIAN_12_06_2022_09_43_12.png.ac6e764a97b70a10084a95e46c77a3d0.png

Edited by barale61
Link to comment

essaye dans les paramètre de ta machine virtuelle

  • Sélectionnez l'option Stockage
  • Cochez "Utiliser le cache d'E/S de l'hôte" pour le contrôleur de disque virtuel
  • Test et erreur : activez et désactivez "Eable PAE/NX", "Enable VT-x/AMD-V" et "Enable nested paging"
  • Démarrer la machine
Link to comment

Salut !

Voici ce que je propose d'après ce que j'ai lu ici et là :

  1. Démarrer la VM à partir d'un arrêt normal complet (pas à partir d'un état sauvegardé).
  2. Continuer jusqu'à ce que le problème se produise, puis arrêter la VM à partir du système d'exploitation de la VM si possible. Si ce n'est pas possible, fermer la fenêtre Virtualbox de la VM avec l'option Power Off donnée.
  3. Cliquer avec le bouton droit de la souris sur la VM dans la liste des VM de la fenêtre principale de Virtualbox, puis choisir Show Log.
  4. Enregistrer le journal (fichier .log) de l'onglet le plus à gauche.
  5. Regarder dans la liste s'il y a ces lignes :
{timestamp} HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
{timestamp} NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...

Ou

{timestamp} HM: HMR3Init: Attempting fall back to NEM: AMD-V is not available
{timestamp} NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...

Si elles sont présentes, c'est que certains services de virtualisation parasitent VirtualBox. Voici ce qu'il faut entreprendre :

  1. Fermer tous les logiciels, éteindre la machine hôte complètement, et la démarrer normalement.
  2. Regarder dans J'ai un hôte 64bit, mais je ne peux pas installer des invités 64bit, 2ème post, points 2 & 3 et s'assurer qu'aucune de ces choses n'est en cours d'exécution :
    • DeviceGuard
    • CredentialGuard
    • Windows Defender's Core Isolation
  3. Chercher l'invite de commande, et la lancer en tant qu'administrateur à l'aide du clic droit.
  4. Entrer les commandes :
bcdedit /set hypervisorlaunchtype off

Certains préconisent aussi cette commande :

DISM /Online /Disable-Feature:Microsoft-Hyper-V

Puis fermer l'ordinateur avec la commande :

shutdown -s -t 2

Bien attendre que le PC soit complètement éteint (pendant 20 sec.) puis rallumer le tout pour tester.

 

Note à postériori :

Citation

L'utilisateur "InfoSecDr" signale qu'une désactivation supplémentaire de l'un des paramètres "DeviceGuard" de Windows dans le registre pourrait être nécessaire pour que Hyper-V soit désactivé :
viewtopic.php?f=6&t=105887&p=517076#p517076

La désactivation de DeviceGuard est l'une des choses demandées pour désactiver Hyper-V.

 

Et si le fichier de log ne contient pas les lignes citées, alors je donne ma langue au chat aussi. :c_tongue:

Link to comment

Bonjour,

Pour essayer de te dépanner il faudrait un peu plus de précisions pour commencer sur ta machine, pour cela tu peux remplir le fichier de configuration ici

Ensuite ou as-tu téléchargé les versions d’ Ubuntu et de Debian, as-tu contrôlé la somme SHA256 de ces distributions GNU/Linux ? Comment as-tu procédé pour l'installation ? Si l'installation arrive à son terme pourrais-tu faire une capture d'écran de la configuration comme chez moi

1096323330_Capturedcrandu2022-06-1419-38-32.thumb.png.14e8eda861b26dbce4cc774ba56b2bac.png  

Tu peux également regarder au niveau de l'USB que l'USB 2/3 ne soit pas coché car si tu as pas les addons installés ta vm ne va pas démarrer

Au plaisir de te relire

Edited by Tulburite
  • J'aime 1
Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...