meridian-shaft Jump to content
Forums

Impossible d'accéder à internet via mozilla sous linux avec ma VM


Solved

Recommended Posts

Bonjour,

Si j'écris ce message c'est parce-que j'ai un petit problème et qu'on m'a recommandé ce site pour trouver de l'aide. J'espère que quelqu'un saura m'aider, je lui en serai en tous cas très reconnaissant.

Alors voilà, cela fait quelques lois que je me suis mis à l'informatique de façon sérieuse car cela m'intéresse et notamment à la sécurité informatique. J'essaye de collecter les outils et les informations nécessaires pour travailler au mieux car cela m'intéresse beaucoup et cela pourra me faire un bagage de plus sur le CV^^.

Depuis que j'ai téléchargé Linux sur une boite virtuelle (VirtualBox - Ubuntu 64 bits) je n'arrive pas à me connecter à internet via mon kali sur VM. J'ai beau essayer de lancer Mozilla changer sur les Paramètres de la VM rien à faire ma machine et mon kali ne veulent rien savoir. On m'a aussi conseillé des lignes de commandes qui se sont toutes avérées inefficaces (sinon je ne serai pas là). Donc si vous avez une idée ici, je suis preneur.

Mais si quelqu'un peut m'aider de quelque manière que ce soit ce serait vraiment gentil de sa part! :)

Merci

Disclammer: Je précise que je ne souhaite en aucun cas faire du "hack" dans le but de nuire à qui que ce soit. Comme je l'ai dit plus haut c'est parce-que cela m'intéresse et je vous l'avoue, cela commence à un peu m'énerver aussi! C'est aussi pour cela,que je demande de l'aide. Merci de votre compréhension.

Merci d'avoir lu jusqu'a la fin.

Link to comment

@Le PoissonClown j'ai suivi ton protocole sur le lien que tu m'as donné mais pas moyen de passer à la 4e image (ou étape). En effet, le truc du pare feu ne s'affiche pas et pas moyen de changer le type de carte et tout ce qui se situe sous la flèche "avancé". Donc la fenêtre ne s'affiche pas même si je clique sur OK. Car tout est déjà mis par défaut donc je sais pas.

Oui je suis un noob

Link to comment

Ah mais je n'ai pas fait attention, excuses-moi ! :drhouse:
En fait, la VM est déjà en NAT, puisque c'est sensé être le réglage par défaut.
Cette histoire de pare-feu n'a rien à voir avec l'accès à Internet, je te rassure. :c_wink:

Tu as essayé quoi comme manip en ligne de commande ? Changer les DNS dans la config d'Ubuntu ?

Côté système hôte, tu n'as pas désactivé une carte réseau virtuelle de VirtualBox ou désactivé le démarrage auto d'un service Windows dédié à VirtualBox par hasard ?

Link to comment

Voilà la igne de code qu'on m'a recommandée "/etc/sysconfig/network-scripts/ifcfg-enp0s3" et tu met onboot à yes.

Après je sais pas comment on fait pour voir si j'ai désactivé une carte réseau virtuelle de VirtualBox ou désactivé le démarrage auto d'un service Windows dédié à VirtualBox. Oui je suis un noob

Link to comment
il y a 55 minutes, IBEN57 a dit :

Après je sais pas comment on fait pour voir si j'ai désactivé une carte réseau virtuelle de VirtualBox ou désactivé le démarrage auto d'un service Windows dédié à VirtualBox. Oui je suis un noob

Ah bah si tu sais pas comment on fait, alors j'imagine que tu ne t'es pas risqué à ce genre de bidouille. La question ne se pose pas.

[Edit : @rodriguem7973 Merci le détail de ces vérifications.]

il y a 55 minutes, IBEN57 a dit :

Voilà la igne de code qu'on m'a recommandée "/etc/sysconfig/network-scripts/ifcfg-enp0s3" et tu met onboot à yes.

OK, ouvre le terminal, et fais un « ping 8.8.8.8 » pour voir si c'est pas le DNS qui pose problème.
Si t'as une réponse sans perte, fais [Ctrl]+[C] pour arrêter le ping, et changes tes DNS :

https://www.youtube.com/watch?v=wjS4eBnR3q0&t=38s

Si tu as une réponse avec pertes, alors je ne vois pas trop d'où peut venir le souci…

Edited by Le PoissonClown
Link to comment
  • 1 month later...

@rodriguem7973

Salut Rodriguem! Alors voilà! Après plus d'un mois pour te répondre (désolé mais j'avais mes examens), j'ai fait ta première commande sur mon kali. Cette commande est :

/etc/init.d/networking restart

et ils m'ont mis: "  Restarting Networking (viasystemctl) : networking.service.  "

Voilà, ça a l'air d'avancer Mais après je fais quoi? Je préfère demander pour ne pas faire une nouvelle be^êtise.

Merci à toi!! Je reste dans l'attente d'une réponse de ta part ou de celle d'un autre.

Iben57

Link to comment

Bon bah je vois pas de quoi tu veux parler. Quand tu dis "faire un test ping" etc. je comprends pas ce que je dois faire concrètement: est ce que je dois écrire quelque-chose dans le terminal, ou alors faire une commande dans les applications, ...

J'ai écrit dans le terminal: " test ping www.archilinux.fr "  (sans les guillemets bien-sur!!) et ça m'a mis " bash: test: ping : opérateur unaire attendu "  (sans les guillemets bien-sur!!).

Maintenant je fais quoi??

J'ai besoin d'explications plus détaillées.

Si je devais reformuler ma question initiale je dirai: Qu'est-ce que tu irai faire pour faire le test ping si tu devais le faire maintanant stp?????????

Link to comment
Le 08/05/2019 à 22:26, Le Crabe a dit :

Salut @IBEN57,

Je n'ai pas bien saisi, c'est Kali Linux ou Ubuntu qui est installé sur la machine virtuelle ?

C'est une machine virtuelle en Ubuntu 64 bits, le système d'exploitation que j'y ai installé est Kali Linux pourquoi?

Tu pourrais m'aider à régler le problème??

Link to comment
Il y a 16 heures, IBEN57 a dit :

C'est une machine virtuelle en Ubuntu 64 bits, le système d'exploitation que j'y ai installé est Kali Linux pourquoi?

Tu pourrais m'aider à régler le problème??

C'est étrange car normalement il n'y a aucune configuration nécessaire, VirtualBox émule automatiquement une carte Ethernet avec la connexion Internet du PC hôte.

Si tu recrées une machine virtuelle en installant Debian netinst (lequel requiert d'avoir une connexion Internet lors de l'installation), est-ce que ça marche ?

Pour télécharger l'ISO de Debian netinstall, voir ici : https://lecrabeinfo.net/installer-linux-debian-pas-a-pas.html

  • Plusser (+1) 1
Link to comment

J'essayerai de faire ça d'ici la semaine prochaine l'ami! Merci de ton aide et je  recontacte si besoin sur ce forum.

Merci à tous pour vos réponses.

IBEN57

PS: C'est quoi la différence entre ubuntu et debian sur un kali sous VirtualBox??

Link to comment

bonjour

le père debian a né un enfant ubuntu :)

un ubuntu est facile pour faire un debutant  et plus tard quand tu fais un niveau pro que ca passe un debian :)

voila

roro

Link to comment
  • 3 weeks later...

Bon, alors j'ai pas essayé d'ouvrir une VM sous Debian (64 bits) car je pense que cela aura le même problème bien que je n'y connaisse pas grand chose. Je m'excuse pour cela :'(

Pour vous donner une idée de mon problème et de mon degré de noobitude lorsque je tape dans mon terminal "git clone ..." ils me mettent "git: commande introuvable" aussi. et je sais déjà pas comment faire.

J'ai encore ce problème et l'impossibilité de se connecter à Mozilla Firefox depuis ma VM avec Kali Linux qui persiste aussi.

Cela me désole et je songe à abandonner même si cela m'ennuie beaucoup. Je ne vois pas pourquoi dans les tutos sur internet ça marche sans problèmes et pas pour moi.

Quelqu'un a déjà ressenti ce que je vous raconte?? Des conseils??

Désolé de vous déranger pour la émième fois mais si encore une bonne âme avait les moyens de m'aider je prendrai parce-que là...

Je suis perdu. I need help

Je suis peut-être le plus gros naze au monde dans ce domaine. Mais j'ai encore envie de progresser

J'essayerai de refaire toutes les commandes qu'on m'a dit dans ce forum rapidement même si j'ai des choses à faire à côté, et je tiendrai au jus si cela intéresse éventuellement quelqu'un.

Cordialement,

IBEN57

PS: Merci en tous cas à tous ceux qui m'ont répondu et à tous ceux qui m'ont aidé de près ou de loin jusqu'a maintenant car c'est important pour moi d'être reconnaissant.

 

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...