meridian-shaft Jump to content
Forums

Problème Windows 10 : pixels qui sautent, applis supprimées, etc ...


Recommended Posts

Bonjour,

Ayant récemment fait l'acquisition d'un pc que j'ai monté ( config en fin de sujet si ça peut aider ), j'ai voulu installer Windows 10 dessus. La version que j'ai acheté m'a couté 45€ car Microsoft voulait l'écouler vu qu'il n'y avait pas une nouvelle mise à jour sur le dvd d'installation. 

J'ai donc monté mon pc sans encombre puis j'ai installé Windows 10 Pro 64 bits. J'ai installé les drivers carte mère à l'aide du disque fourni, puis j'ai mis à jour windows, et enfin j'ai installé les drivers de la carte graphique car il n'étaient pas compatibles si je ne mettais pas à jour Windows.

Tout se déroule très bien et au bout de deux jours tous mes drivers et les applications étaient installées sans problème.

Pour plus de compréhension, je vais vous décrire ce qui s'est passé précisément étape par étape cinq jours plus tard :

- je regarde une vidéo et je me dis que je vais jouer à Rust ( jeu en alpha que j'adore )

- je lance le jeu et je switch de fenêtre pour continuer de regarder ma vidéo pendant le chargement du jeu

- je retourne sur la fenêtre du jeu quelques secondes plus tard : le jeu était figé, la fenêtre était noire, je clic sur l'icon croix pour fermer le jeu

- je relance le jeu : pareil jeu figé, fenêtre noire, je retente de fermer la fenêtre mais ce coup-ci elle refuse et 3 petist carrés bleus et blancs apparaissent ; je redémarre le pc

- là l'affichage commence à partir en cacahuètes, à chaque mise à jour d'une fenêtre, des petits carrés de la taille de quelques pixels apparaissent puis disparaissent sans raison apparente

- je redémarre le pc et là c'est la mort : même problème au niveau de l'affichage mais en pire mais je me rends compte d'autre chose : dans le menu Windows, les suggestions ont disparu, je n'ai accès qu'aux applications et à la fonctions éteindre le pc, et dans les applications, toutes celles fournies avec Windows ont disparu, et pareil dans la barre des tâches. Mais dans le bureau, j'avais épinglé Edge ( fourni avec Windows ) et il y apparaissait toujours et pouvait toujours être ouvert mais n'apparaissait pas dans la liste des applis

- j'éteins le pc, j'enlève le SSD, je le formate à l'aide de mon mac, je le remets dans le pc, et je lance le programme d'installation Windows à l'aide du disque d'installation

- là petit problème mais qui n'a je pense rien à voir avec le reste : le SSD n'était pas au bon format je le passe donc en GPT à l'aide de DiskPart

- je réinstalle Windows et les drivers de la carte mère, ainsi que les mises à jour Windows

- après redémarrage je mets à jour tous les drivers à l'aide de MSI Live Update et au moment ( je n'ai pas bien pu voir car je faisais autre chose ) soit de la mise à jour du pilote BlueTooth soit de la mise à jour du pilote du Chipset carte mère, re le même problème, de pixels commencent à sauter dès que je mets une fenêtre à jour

- déception, j'abandonne, j'arrête la mise à jour et j'éteins le pc

Je ne sais pas ce qui a bien pu déclencher ce problème car la première et la deuxième fois ce n'était pas la même chose. Je ne sait pas de quel(s) composant(s) cela peut venir ou de Windows lui-même ; d'autant plus que je n'ai pas de pc ou de matériel de test sous la main donc je ne peux pas localiser le problème.

Comme dit dans l'introduction, si cela peut aider, voici ma config :

- Proco : Intel i7 6700k

- Carte mère : MSI Z170A Tomahawk AC

- Carte graphique : Asus Strix GTX 1060 6G

- RAM : G.Skill DDR4 2400 Mhz 4x4 Go 

- Watercooling : Cooler Master Seidon 120 v2

- SSD : Corsair Force LE 240 Go

- HDD : Seagate Barracuda 1 To

- Boitier : Corsair Carbide SPEC-03

- Alim : Corsair CX550M

- Tout le reste : Ventilateurs ARCTIC F12 x3 ; Pâte Thermique ARCTIC MX-2 8 g ; etc...

Merci d'avance à tout le monde pour votre aide !

( Excusez-moi je ne peux pas prendre de photos de mon écran pour illustrer mon problème. )

 

Link to comment

bonjour,

petite première erreur, sans vous gronder hein :P ,  évité de faire plusieurs choses sur votre ordi sa évite au procos et au mémoire de devoir se scinder en deux pour faire le travail pendant une installation de x ou y ...
deuxième erreur, plus conséquente celle là, ne jamais formater un disque dur puis ensuite l'installer dans un autre pc, lors du formatage ou du lancement, le bios et ou le pc met des petites info a sont sujet " sa config " dans le disque dur etc

pour ma part, il dois rien y avoir de grave, c'est juste surement un pilote qui n'est pas bien compatible avec votre pc ou windows.

pour ma part, je ferai la manipulation suivante:
formate votre pc, et un a un mettre les pilotes, faire avant chaque nouveau pilote un point de restauration.

mettre votre drivers carte graphique un point avant l'installe et vous attendez 1 a 2 jours, puis ainsi de suite pour tout les autres.
vous finirez par tomber sur celui qui met la misère... et vous aurez toujours un point de restauration avant chaque nouveauté pour reculer en arrière..

manipulation longue mais plus fiable que tout mettre et attendre un crash

++

Edited by Delta
  • Plusser (+1) 1
Link to comment

Salut @EnjoyPotato, salut @delta 

Effectivement win 10 est assez sensible au niveau des drivers et dernière techno.


Le cd qui contient les drivers de ta carte mère MSI sont anciens, as tu essayé d'aller sur le site constructeur et de mettre la dernière maj du bios( le bios c'est très sensible/ suivre les instructions constructeur à la lettre et ne pas toucher même si çà redémarre 10 fois ) et les derniers drivers ? 

J'ai eu des problèmes de stabilité avec mon i3-6100, ce sont les dernières majs qui ont stabilisé mon système, j'ai reinstallé plusieurs fois mon système comme Delta t'a proposé ( a peu près ) mais c'était pas sa ^^ Moi je mets les dernières majs une à une, redémarrage à chaque fois et sans connexion internet pour pas que windows update mette à jours les drivers en même temps que moi !

Voilà pour une deuxième piste si la solution de Delta n'a pas marché :) 

a+
 

  • Plusser (+1) 1
Link to comment
il y a 3 minutes, CoffeeFou a dit :

redémarrage à chaque fois et sans connexion internet pour pas que windows update mette à jours les drivers en même temps que moi !

correct, @CoffeeFou a bien bien dit,  j'y pense jamais mais c'est logique, microsoft est tellement intrusif qui veut tout mettre a sa sauce ... et tout le monde sais du moins ceux qui font souvent des installation etc que les drivers windows sont pas tous compatible ...

 

++

Link to comment

Salut à vous tous,

Je ne me souviens plus si il est possible de désactiver la mise à jour des pilotes via Windows Updates avec Windows 10 Famille ?

Mais, si vous voulez désactiver définitivement la recherche des pilotes avec une édition Famille.

  1. Vous lancez l'Invite de commandes (Admin).
    REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DriverSearching" /v SearchOrderConfig /t REG_DWORD /d 0x00000000
  2. Vous validez.
  3. Vous refermez l'Invite de commandes, et voilà !

Plus de souci avec Windows Update qui essaie de vous installer vos pilotes !

Et, pour réactiver la recherche, vous changez la ligne de commande par celle-ci:

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DriverSearching" /v SearchOrderConfig /t REG_DWORD /d 0x00000001

Important: respectez les espaces devant les “ / ”.

A+:c_wink:

Edited by Le PoissonClown
Mise en forme des lignes de commande
  • Plusser (+1) 1
Link to comment
Il y a 4 heures, Yves B. a dit :

Je ne me souviens plus si il est possible de désactiver la mise à jour des pilotes via Windows Updates avec Windows 10 Famille ?

Mais, si vous voulez désactiver définitivement la recherche des pilotes avec une édition Famille.

Merci pour ton aide mais est-ce que cette technique est compatible avec Windows 10 PRO ?

Merci d'avance !

Link to comment

Salut @EnjoyPotato,

il y a une heure, EnjoyPotato a dit :

est-ce que cette technique est compatible avec Windows 10 PRO ?

Oui, pour que Windows ne fasse plus la mise à jour des “ pilotes ”.

Mais, puisque tu as une version “ Pro ”, tu peux utiliser « gpedit.msc ».

Dans « Exécuter », tu tapes « gpedit.msc », et clic “ OK ” (capture #1).

Dans la nouvelle fenêtre (capture #2), tu déploies l'arborescence: Configuration de l'ordinateur ==> Modèles d'administration ==> Composants Windows ==> Windows Update sur lequel tu cliques.

Dans la partie de droite, tu recherche « Ne pas inclure les pilotes avec les mises à jour Windows » sur lequel tu double-cliques, dans la nouvelle fenêtre, tu coches « Activé » (capture #3), ensuite tu cliques sur « Appliquer », ensuite « OK », et tu refermes le tout.

Mais c'est plus rapide de passer par l'Invite de commandes (Admin).

A+ :c_wink:

Exécuter.PNG

Capture.PNG

Activé.PNG

Edited by Yves B.
Link to comment

Re-bonjour,

J'ai potentiellement trouvé la solution. Selon un ami depuis longtemps sur W10 et ayant eu le même problème, le problème viendrait du fait que la carte graphique soit trop puissante et que la carte mère n'arrive pas à suivre.

Les cartes mère de chipset Z170 sont sorties pendant la 9ème génération de carte graphique. Mais entre la 9ème et la 10ème génération de carte graphique, il y a eu des changements énorme. Exemple : chez MSI, entre la 960 GAMING 4G et la 1060 GAMING 6G, on a gagné 2 Go de VRAM, 300 Mhz en non-boost, 450 Mhz en boost, etc...

Les cartes mère de chipset 100 séries ( Z170, B150, H110, H170, Q170, etc... ) ne sont donc pas assez rapides et n'arrivent pas à suivre quand la carte graphique dépasse une certaine fréquence, atteinte notamment lors de l'ouverture d'une fenêtre et faisant donc apparaitre ces fameux pixels.

Pour la première fois où le bug est apparu sur mon pc, je pense que c'est à cause du jeu qui a crash et donc a poussé la carte graphique et le proco au max, et saturant donc la carte mère, ce qui a aussi ( je pense ) causé le problème de applications Windows qui ne s'affichaient pas. La deuxième fois, au moment où la carte graphique a commencé à être utilisée, le problème c'est reproduit.

Il ne me reste plus qu'à trouver comment débrider la carte mère ( si on peut pour pouvoir atteindre les mêmes fréquences que le GPU ) ou comment underclocker le GPU pour atteindre des fréquences compatibles avec la carte mère ( même si, personnellement ça m'embête un peu pour être poli ).

Après ce n'est qu'une théorie, reste à savoir si c'est la bonne ...

Merci de votre aide !

 

Link to comment
il y a 12 minutes, EnjoyPotato a dit :

J'ai potentiellement trouvé la solution. Selon un ami depuis longtemps sur W10 et ayant eu le même problème, le problème viendrait du fait que la carte graphique soit trop puissante et que la carte mère n'arrive pas à suivre.

cela serai bien la première fois que j’entends cela ... ( je ne remet pas en doute les dire de la personne là n'est pas mon intervention )

mais alors si je suis cette soluce, il vaudrai mieux ne jamais upgrader un pc avec une carte graphique après un laps de temps car les générations ont évolué...

donc encore en suivant cette logique, une carte mère un peut ancienne mais qui détient un port pciE 16x une fois qui l'as pris 5 a 7 ans d'age c'est finit...

 

bien souvent ont est bloquer par le port et le format, pour les Ram ben DDr DDR2 etc et le nombres de pin 186pin etc se qui correspond a des DDR etc

le format carte graphique pci agp etc mais j'ai jamais entendu un blocage de fréquence, sachant que sur les ram par exemple elle se mettent a la fréquence que permet la carte mère...

 

je ne sais pas ...

Edited by Delta
Link to comment

Je rejoins @Delta,

Il y à beaucoup plus de sécurité qu'avant ça me parait chelou ! Avant de toucher quoique ce soit contact le constructeur de la carte mère qui à déjà peut être eu des retours !


Bah oui ce serait dommage de faire joujou et risquer un si beau matos si le constructeur à la solution ^^ 

Tu peux aussi effectuer un test sous usb live de linux, tu test si tu as le même problème. 

Si entre deux os ca fais le même problème au même endroit c'est peut être un défault constructeur.

Voilà, beaucoup de patience il faut, te dirais maitre Yoda xD


 

  • Plusser (+1) 1
Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...