meridian-shaft Jump to content
Forums

Boot Linux freeze


Solved

Recommended Posts

Bonjour, 

J'ai un Acer Swift 3 314-41-R1X6, mon problème est que après avoir sélectionné "Installer Ubuntu" dans le GRUB, 15 secondes après l'écran de chargement Ubuntu "freeze" et je dois éteindre le PC. J'ai essayé d'ajouter "nomodeset" dans le grub mais aucun changement.

Est-ce que vous avez une idée d'où viens le problème ? 

Merci

Link to comment

Bonjour, 

Merci de ta réponse.

J'ai essayé de d'installer ubuntu 18.04 et 19.04 mais aucun changement toujours le même problème.

Le problème vien visiblement du processeur graphique vega 8, as tu l'as solution? (Et oui mon pc est un vrai Acer Swift 3 314-41-R1X6)

Merci !

 

Link to comment

Bonsoir @Fiaor et bienvenue sur le forum ! :c_happy:

Essaie de modifier les paramètres acpi en mettant ça : acpi_osi=! acpi_osi=\"Windows 2009\

Rappel de la méthode pour rendre les paramètres définitifs une fois arrivé sur Ubuntu :
 

sudo nano /etc/default/grub

Ajoute acpi_osi=! acpi_osi=\"Windows 2009\" comme ci dessous :

GRUB_CMDLINE_LINUX_DEFAULT ="quiet [...] acpi_osi=! acpi_osi=\"Windows 2009\""

Mets ensuite à jour GRUB pour qu'il prenne en compte cette modification :

sudo update-grub

Redémarre ton PC.

Si cela ne marche pas, essaie acpi=off

Edited by Mreve
Précisions
Link to comment

Bonsoir, merci pour l'accueil et ta réponse.

Par contre je ne sais pas ou est ce que je dois entrer sudo nano /etc/default/grub (je n'ai que accès à windows)

 

J'ai essayé en editant directement "install xubuntu" dans le grub et après avoir ajouté juste après "quiet splash":

-" acpi_osi=! acpi_osi=\"Windows 2009\" " écran noir 

-" acpi=off " message d'erreur : [     5.731113] Couldn't get size:0x800000000000000e

D'ailleurs je ne sais pas si cela a un rapport ou non mais pour information mon grub est très très lent.

 

Merci

Link to comment
Le 08/11/2019 à 17:12, Fiaor a dit :

Par contre je ne sais pas ou est ce que je dois entrer sudo nano /etc/default/grub (je n'ai que accès à windows)

C'est ma faute. J'ai oublié quelques précisions dans mon message. Cette méthode permet de pérenniser la modification. J'ai édité mon premier message.

Éditer un paramètre kernel au niveau de Grub n'est que temporaire (seulement pour ce démarrage).

Le 08/11/2019 à 17:12, Fiaor a dit :

J'ai essayé en editant directement "install xubuntu" dans le grub et après avoir ajouté juste après "quiet splash":

Oui tu as bien fait.
 

Je n'avais pas fait gaffe mais je crois savoir pourquoi tu as des problème. Tu essaies d'installer Ubuntu sur un PC portable extrêmement récent.

À mon avis, passer sur le kernel 5.3 devrait aider (j'en suis même quasiment sûr). Utilise çe script.

Tu vas avoir besoin utiliser un ISO d'Ubuntu sur USB pour chroot dans ton système. À partir de là tu pourras lancer le script pour récupérer ce nouveau kernel.

Je parle chinois ou tu penses y arriver tout(e) seul(e) ?

N'hésite pas si tu as besoin d'aide. :c_happy:

EDIT : Sur les PC vraiment très récent, je trouve plus simple d'utiliser des distributions bleeding edge comme Archlinux (pour utilisateurs avancés) EndeavourOS (Archlinux avec installeur tout fait) ou SolusOS (débutant)

Note : Une distribution bleeding edge est une distribution qui propose toujours les dernières versions des logiciels. Elle est également en rolling release, c'est à dire que les mises à jour sont constantes.

Les ISO embarquent donc toujours la dernière version du noyau. Contrairement à Debian & Cie qui ont des versions bien plus vieilles pour des raisons de stabilité.

Edited by Mreve
Link to comment

Bonjour, merci de ta réponse.

Je n'ai pas compris désolé ^^' 

Je ne sais pas comment utiliser le script,, ni chroot.

Utiiliser un iso ubuntu sur usb c'est un usb bootable ubuntu?

PS: j'essaie d'installer xubuntu (désolé j'avais mit ubuntu dans mon premier message) ce script fonctionne aussi pour xubuntu ?

Merci beaucoup

 

Link to comment

Pas de soucis ! :c_happy:

Il y a 1 heure, Fiaor a dit :

Utiiliser un iso ubuntu sur usb c'est un usb bootable ubuntu?

Oui. L'idée derrière c'est de pouvoir démarrer le PC depuis l'ISO de la clef USB.

Un grand avantage de Linux c'est qu'il est facilement possible de basculer sur le système installé sur le PC depuis un ISO bootable. C'est la commande chroot (changeroot) qui permet de faire ça.

Cette méthode est très pratique pour dépanner un système Linux qui ne veut plus démarrer. Une fois "chrooté" dans ton système tu peux réparer ton OS. En l'occurrence ici, il faut installer une version plus récente du kernel.

Il y a 1 heure, Fiaor a dit :

PS: j'essaie d'installer xubuntu (désolé j'avais mit ubuntu dans mon premier message) ce script fonctionne aussi pour xubuntu ?

Quelle est la raison qui t'a incité à installer Xubuntu au lieu d'Ubuntu ? De mon point de vue, Xubuntu c'est bien pour les PC un peu faiblard ou pour les gens qui n'aiment pas l'environnement de bureau Gnome (et qui n'ont pas envie de bidouiller pour installer autre chose).

Si tu veux essayer autre chose que Gnome, je te conseille vivement Ubuntu Budgie :


Enfin bref, j'ai une solution plus simple à ton problème : installe la version 19.10 de Xubuntu ou Ubuntu. Cette version intègre la version 5.3 du kernel.
 

PS : Je pars me balader, il fait beau où je suis. Je serai disponible en fin d'après-midi si tu as des questions. :c_happy:

Edited by Mreve
PS
Link to comment

Merci beaucoup pour ces réponses rapides.

Je voulais installer le même os que sur les pc de mon université donc xubuntu. Je pensais avoir déjà essayé ubuntu 19.10, je vais donc essayer de l'installer.

Merci et désolé de répondre si tard, bonne soirée !

 

Edited by Fiaor
Link to comment

Après avoir essayé, je retrouve le même problème quand essayant d'installer ubuntu 18.04:

Message d'erreur : "[     0.716058] pci 0000:00:00.2: AMD-Vi:Unable to write IOMMU perf counter."

suivi du logo ubuntu et de son chargement qui se freeze une vingtaine de secondes après.

Link to comment

On va y arriver, on va y arriver... Nestor

 

Il y a 5 heures, Fiaor a dit :

Iommuu=soft ne donne rien (avec deux 'u')

Je sais pas pourquoi j'ai écris ça avec 2 "u".:c_coldsweat:

J'ai corrigé.

Bon je tente un dernier truc :

idle=nomwait nvme_core.default_ps_max_latency_us=5500

Seulement ces 2 paramètres (pas de iommu=soft).


J'ai trouvé ça ici. L'utilisateur semble avoir exactement le même problème que toi. Si ça marche pour toi, je t'expliquerai ce que font ces 2 paramètres.

EDIT :

@Fiaor

Dans le doute, au cas où ça ne fonctionne pas, essaie juste ce paramètre :

nvme_core.default_ps_max_latency_us=0

 

Pas de bol que l'install d'Ubuntu soit si pénible pour toi. :c_sad:

Link to comment

Salut,

"idle=nomwait nvme_core.default_ps_max_latency_us=5500" à bien fonctionné je l'ai ajouté à "/etc/default/grub" et ubuntu démarre donc correctement.

CEPENDANT (eh oui ^^'), lorsque je lance ubuntu, l'os plante au bout de 10-15 secondes après avoir choisi mon utilisateur. Au début je pensais que j'avais mal ajouté la ligne dans "/etc/default/grub", j'ai donc réinstallé 3-4 fois mais aucun changement...

Désolé d'avoir mit autant de temps à répondre, j'étais un à bout x) 

Merci !

  • J'aime 1
Link to comment
il y a 2 minutes, Fiaor a dit :

"idle=nomwait nvme_core.default_ps_max_latency_us=5500" à bien fonctionné je l'ai ajouté à "/etc/default/grub" et ubuntu démarre donc correctement.

Aaah ! Bonne nouvelle !
 

il y a 3 minutes, Fiaor a dit :

Au début je pensais que j'avais mal ajouté la ligne dans "/etc/default/grub", j'ai donc réinstallé 3-4 fois mais aucun changement...

Tu n’aurais pas, par hasard, oublié de faire

sudo update-grub

après avoir modifié /etc/default/grub ?

Link to comment

Oui bien sûr. C'est ce que je comptais faire. :c_happy:

idle=nomwait : empêche la "veille" (comprendre "tourner au ralenti") agressive du processeur. Cela a pour but d'empêcher un bug avec les récents CPU AMD et les récents build du noyau Linux.

nvme_core.default_ps_max_latency_us=5500 : Désactive l'état le plus bas de sous alimentation (comprendre "économie d'énergie") pour éviter un bug qui crée des erreurs d'écriture sur certains SSD NVME Samsung récents.

Pour enlever ce paramètre il faudrait une mise à jour du firmware du SSD ou un fix dans le noyau Linux qui colle avec ton SSD. Il y a déjà eu un correctif dans la v4.11 mais apparemment ça n'a pas réglé le problème pour tout le monde.

Je te conseille de surveiller les mises à jour du SSD : https://www.acer.com/ac/fr/FR/content/support-product/8036?b=1

Pour l'instant il n'y a rien mais mais peut-être qu'un jour... qui sait...

Il peut aussi y avoir du neuf côté kernel Linux et/ou des mises à jour du BIOS (pour l'instant il n'y a rien)

Le mieux c'est de surveiller les news de la communauté Linux à propos de ton PC :

https://www.google.com/search?hl=en&q=Swift+3+SF314-41+"Linux"

Tu pourras essayer d'enlever un des 2 paramètres (puis les 2) à chaque mise à jour du kernel. Il y a plus de chance que tu puisse enlever le idle=nomwait.

Edited by Mreve
Link to comment
  • Mreve featured and unfeatured this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...