Jump to content
Communauté

PetitPoisson

Membres
  • Content Count

    60
  • Joined

  • Last visited

Community Reputation

5 Neutre

About PetitPoisson

  • Rank
    Matelot

PC settings

  • Système d'exploitation
    Windows 10

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @Monteau13 Sauf les douches à payement sans contact.
  2. (ça ne me dérange pas qu'on me tutoie.) J'ai limité le script à deux dossiers, et ça fonctionnait partout pour les documents et les téléchargements. Mais là, je re-teste avec tous les dossiers, et dans la partie "Ce PC" ça ne fonctionne pas pour le raccourci vers le dossier d'images ou de vidéos par exemple (bien que ça fonctionne pour celui des téléchargements/documents). … j'espère que le script powershell sera plus carré, parce que là c'est à s'arracher les cheveux.
  3. Merci bien, @Longaripa J'ai regardé dans mon registre et mis à part pour le dossier de téléchargement, je n'ai aucune de ces valeurs avec des ID pour les dossiers utilisateur qu'on veut déplacer. Je trouve ça bizarre. Et j'ai remarqué aussi une chose encore plus problématique : même si je change le contenu de toutes ces valeurs, les raccourcis dans "Ce PC" ne fonctionnent pas. Et je suis tombé sur un article qui explique qu'il ne faut pas jouer avec ces clés si je comprends bien : https://devblogs.microsoft.com/oldnewthing/20110322-00/?p=11163 Et plutôt utiliser une fonctio
  4. @Toto61 En fait, le script v.2 n'a aucune adresse de destination, il se base sur le répertoire depuis lequel on le lance. Si on lance le script depuis le répertoire "N:\Machin", il copiera les dossiers vers ce répertoire. Et je pense que j'ai compris où est le problème (mais du coup je comprends pas pourquoi ça marche chez moi) : Lorsqu'on lance le script, il avertit de l'emplacement où les dossiers vont être copiés. Et comme je le lance dans "D:\DONNEES" chez moi, il m'écrit l'adresse "D:\DONNEES\" comme résultat de la variable du répertoire en cours (avec une barre oblique à la f
  5. Je crois que ce qu'il veut c'est gagner du temps avec un script qui fait tous les changements d'un seul coup, au lieu de se taper toutes les manipulations une par une dans le registre. Mais tester la modification du registre à la main, pour voir si le problème vient du script ou du choix des clés de registre. C'est une très bonne idée, je trouve.
  6. Merci j'ai ce lien seulement pour celui que j'ai publié, donc je vais pouvoir le modifier au cas où. Mais je n'ai pas ce lien pour mon post en mode brouillon (non-publié). Et je n'ai rien pour le supprimer non-plus.
  7. Bonjour, J'ai ouvert mon blog sur ce site pour essayer, et je me demandais comment le supprimer, je ne vois pas de lien pour ça. Du coup pour pas avoir la honte (genre, t'ouvres un blog, il est vide nan mais allo kwa!), j'ai commencé à écrire un tuto et comme il n'était pas fini, je l'ai mis en non-publié comme brouillon. Je suis revenu plus tard pour le modifier, et pas de lien pour le modifier, j'ai cherché partout. Donc j'ai créé un nouveau tuto, pour recopier tout, et ajouter la suite. Là je l'ai publié, et cette fois j'ai le lien pour le modifier. Mais je ne peux rien s
  8. Vous cherchez souvent votre pointeur de souris ? Vous voulez que votre souris soit visible pendant une démo sur une vidéo ou une projection ? Il y a une solution facile : Télécharger un curseur avec un halo ici : http://www.rw-designer.com/cursor-set/highlighted Pour l'installer, c'est dans les options de la souris : Faites le raccourci touche Windows + R, et tapez : Validez. Dans les options de la souris, allez dans l'onglet "Pointeurs". Dans l'onglet, sélectionnez le pointeur normal, et cliquez sur le bouton "Parcourir" pour ouvrir votre pointeur
  9. OK. C'est pareil chez moi. Donc le problème est ailleurs. Est-ce que, à tout hasard, tu ne réponds pas "o" ou "oui" dans le script pour valider chaque modification de ces entrées dans le registre ?
  10. Oui ça fonctionne nickel. J'ai tous les raccourcis de l'explorateur qui marchent. Je comprends pas d'où vient le pbm. Ou alors c'est mon Windows 10 qui est trop vieux, et le fonctionnement des clés de registre pour les raccourcis des dossiers utilisateurs dans l'explorateur a changé !? ça m'étonnerais. Si tu crées un nouvel utilisateur, et que tu ouvres une session pour regarder le registre, tu as quoi comme valeurs dans la clé ci-dessous ? "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"
  11. Bonjour, Je signale un blocage qui m'est arrivé ici : Le site n'aime pas ce que j'ai écrit dans mon script. Voilà l'erreur : J'ai contourné le problème, donc pas de souci pour moi, c'était juste pour prévenir.
  12. Même après avoir fermé et rouvert la session ? Là je ne sais pas comment ça se fait, surtout si y-a pas d'erreur !
  13. Il faudrait le lancer en tant qu'administrateur, pour éviter ces erreurs. Et une fois que le script a terminé, fermer la session et la rouvrir pour que les dossiers pointent au bon endroit. Est-ce que c'est ce que tu as fait ? J'ai modifié le script en conséquence : il se base sur le répertoire cible en cours, il relance le script en tant qu'administrateur au besoin, et il ferme la session à la fin, pour que les changements soient appliqués. Tu le trouveras ici : https://sebsauvage.net/paste/?83b14fdb35c47ad9#EzHGN8R6qZvyVFF048UyvsZUdO+w+nCym8CWDyLK9w0= PS: @cali
×
×
  • Create New...