meridian-shaft Jump to content
Forums

Ubuntu ne reconnais pas windows pour installer le dual boot


Recommended Posts

Bonjour,

J'ai scrupuleusement suivi le tutoriel pour installer ubuntu en dual boot avec Windows 10 cependant au moment de l'installation, il ne m'est pas proposé d'installer ubuntu à coté de windows boot manager. Il est écrit qu'aucun système d'exploitation n'est trouvé sur mon disque dur.... Après moultes recherches je n'ai trouvé aucune solution à mon problème...
J'ai pourtant bien désactivé le démarrage rapide de windows et supprimé le RAID  mais rien n'y fait mon OS n'est pas reconnu ...
Je me demandais donc si à tout hasard vous aviez quelques idées afin de m'aider à résoudre ce problème..

Je vous remercie d'avance pour l'aide que vous allez m'apporter.

Edited by guillaume
Link to comment

Tout simplement avec cet excellent tuto.

https://lecrabeinfo.net/reparation-reinitialiser-reparer-windows-10-sans-perdre-ses-donnees.html

Lis le entièrement et attentivement en entier avant de choisir la méthode qui te convient le mieux, sachant que c'est la n°2 qui te permet de conserver fichiers et applications.

Tu peux sans aucun problème réinstaller W10.

Edited by zelandonii
Link to comment
il y a 27 minutes, guillaume a dit :

Le tuto est bien fait , j'ai réussi à réinstaller W10 sans perdre aucune données ni application cependant je ne peux toujours pas utiliser l'option Dual Boot lors de l'installation d'Ubuntu...

est ce que tu as réussi à installer ubuntu ? ou bien tu ne peux toujours pas l'installer ?

Link to comment

Re,

bon alors voici ce que j'ai trouvé sur des forums anglais concernant ce probleme :

Citation

Assurez-vous que vous avez désactivé le démarrage rapide dans Windows et effectuez un arrêt complet en maintenant la touche Maj enfoncée lorsque vous cliquez sur Arrêter pour désactiver le démarrage rapide. Si vous ne le faites pas, la partition Windows ne peut pas être montée par Linux pour vérifier qu’il existe une partition Windows.

et voici une autre solution, il est mentionné que le "secure boot" dans le bios peut etre à l'origine du probleme que tu rencontres :

Citation

Je sais que c'est trop tard pour OP, mais pour quiconque googler, pour moi, c'était le "secure boot". J'ai d'abord essayé de désactiver le "secure boot" via le BIOS, mais pour une raison quelconque, l'option était cachée derrière CSM  que j'ai désactivé, puis je pouvais désactiver le démarrage sécurisé. J'ai ensuite été autorisé à installer Ubuntu à côté de Windows.

j'espere que l'une de ces 2 solutions pourra resoudre ton souci.

Link to comment

zelandonii ,

Je n'ai pas réinstallé W avec un ISO mais avec l'outil Création de média (les deux possibilités étaient mentionnés dans le tuto)

mehdibleu,

J'ai bien désactivé le démarrage rapide et le secure boot. Cependant, CSM est activé mais je n'ai pas bien saisi  ce que c'était ..

Je précise que mon HDD est en MBR  et pas de UEFI (ça non plus j'ai pas ultra bien saisi...).

Link to comment
Il y a 4 heures, guillaume a dit :

Je ne dois pas enlever CSM car si je le désactive je ne peux plus boot sur Windows...

oui pardon, tu as raison, il faut laisser CSM activé dans ton cas.

dis moi quel outil tu as utilisé pour rendre une clé usb bootable avec ubuntu ?

Si tu as créé un clé bootable avec ubuntu en UEFI alors tu peux etre sûr que le probleme vient de la, du moment que ton windows 10 a été installé en legacy bios (CSM), il faut que ubuntu soit lui aussi installé avec le meme mode de configuration (CSM).

donc utilise rufus et fais en sorte que ce soit le mode "MBR pour bios" qui soit selectionné avant de créer la clé usb et tu vois ce qui se passe.

Link to comment
il y a 14 minutes, guillaume a dit :

J'ai bien créer un clef USB bootable avec Rufus. J'ai bien choisi la fonctionnalité MBR pour "Bios ou UEFI " (il n'y a pas juste Bios ou juste UEFI) cependant, j'ai quand même l'impression que la clef se lance en UEFI a partir du Bios...

pour que ce soit clair, quel mode est configuré dans ton bios ? UEFI ? UEFI + Legacy bios ? legacy bios ?

si ton bios n'est pas configuré en UEFI alors il n'y a aucune raison que la clé se lance en UEFI.

Link to comment

@guillaume

Je pense que ce probleme que tu rencontres ne peut venir que de la configuration du bios.

voila ce que tu vas faire, tu vas recréer ta clé bootable ubuntu avec rufus mais cette fois tu telecharges la derneire version de rufus (3.4), la derniere version fait en sorte de créer une clé bootable en focntion du mode bios deja configuré dans le bios.

Donc tu lances rufus depuis windows 10 sur la machine sur laquelle tu veux faire un dual boot et tu crée ta clé bootable, tu bootes avec et tu vois ce qui se passe.

si cela ne donne rien, essaie cette solution (trouvée sur un forum anglais)

Vous devrez le faire sous Windows:

    ouvrez le panneau de configuration puis  chosiissez "options d'alimentation"
    cliquez sur "choisir l'action du bouton d'alimentation"
    cliquez sur "Modifier les parametres actuellement non disponibles"
    décocher démarrage rapide
    fermez le panneau de configuration
    ouvrir une fenêtre d'invite de commande administrative
    tapez powercfg / h off (désactive l'hibernation)
    tapez chkdsk /f c:
    approuver que chkdsk s'exécute au prochain démarrage
    redémarrer Windows

 

Link to comment

J'ai effectué les solutions que tu viens de me proposer mais rien a changé.

Quand je regarde comment est fait mon Bios , je ne trouve pas si c'est UEFI ou Legacy bios... Le seul truc que j'ai trouvé c'est "Hérité".

Ensuite, j'ai 4 partitions sur mon HDD , est-ce que ça pourrait venir de là ?

Link to comment
il y a 4 minutes, guillaume a dit :

J'ai effectué les solutions que tu viens de me proposer mais rien a changé.

Quand je regarde comment est fait mon Bios , je ne trouve pas si c'est UEFI ou Legacy bios... Le seul truc que j'ai trouvé c'est "Hérité".

Ensuite, j'ai 4 partitions sur mon HDD , est-ce que ça pourrait venir de là ?

Hérité veut dire Lagacy bios (bios traditionnel)

un screen serait le bienvenue, va dans gestion des disques et tu fais stp un screen

bon va dans "gestion des disques" et puis tu va sur "disque 0" (celui qui correspond au HDD sur lequel est installé win10", tu fais cliques droit puis "proprietes" puis tu vas dans l'onglet "volume " et tu me dis tu vois apparaitre "GPT"

Link to comment
à l’instant, guillaume a dit :

AH ben oui alors ! Du coup ça voudrait dire que s'en est fini pour le dual boot ... ? (snif...)

oui à moins que tu décides de supprimer une des partitions mais je ne le te conseilles pas parce que tu pourrais te retrouver dans de sales draps. La seule que tu pourrais peut etre supprimer c'est la partition E:

que contient cette partition ? c'est une partition de donnée ? est ce qu'elle contient des dossiers telechargements (des fichiers qui sont directements transférés vers la partition E à partir de C: apres leur telechargement ) qui sont en lien direct avec la partitiion c: ?

il aurait fallu l'installer en UEFI et tu aurais pu créer autant de aprtitions que tu le souhaites (max 128)

 

Link to comment

Effectivement, je pense que si les partitions sont comme cela, c'est qu'il y a une raison...

La partition E contient seulement des données. Il ne me semble pas qu'il y ait quoi que ce soit qui transite automatiquement entre C et E.

Le problème c'est que c'est pas moi qui ait installé ce disque . C'est un réparateur qui me l'a installé suite au cassage de l'original....

Il n'y a pas moyen de passer de MBR à UEFI sans tout recommencer à zéro ?

Link to comment
à l’instant, guillaume a dit :

Effectivement, je pense que si les partitions sont comme cela, c'est qu'il y a une raison...

La partition E contient seulement des données. Il ne me semble pas qu'il y ait quoi que ce soit qui transite automatiquement entre C et E.

Le problème c'est que c'est pas moi qui ait installé ce disque . C'est un réparateur qui me l'a installé suite au cassage de l'original....

Il n'y a pas moyen de passer de MBR à UEFI sans tout recommencer à zéro ?

Non pas que je sache.

Il n'est pas recommandé de le faire en général parce que pendant la conversion, il y a un risque pour que l'utilisateur perde toutes ses données.

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...