meridian-shaft Jump to content
Forums

Désactiver la touche VERR. MAJ


Solved

Recommended Posts

Note de modération : Cette demande à été tirée d'une autre discussion, car elle mérite son propre fil de discussion.

il y a 18 minutes, Le PoissonClown a dit :

@papijo : est-ce que ce message problématique rend impossible autre chose que la personnalisation des touches MAJ ?

Si ce n'est pas le cas, je pense qu'il serait plus simple de contourner le souci avec un logiciel, non ?

Bonne question, @Le PoissonClown en effet c'est le seul problème que je rencontre, donc essayer toutes ces solutions (qui ne marchent pas) est du temps perdu et revient à écraser une mouche avec un marteau-pilon.

En revanche j'ai cherché et pas trouvé de soft qui me permettrait juste de modifier le fonctionnement des touches MAJ et MAJ Lock. C'est-à-dire la possibilité de déverrouiller MAJ LOCK avec la touche MAJ. Bon, on va chercher...

Edited by Le PoissonClown
Citation du message précédent + note
Link to comment

Hello

Programmer des touches fonction avec AutoIt et AutoHotkey

AutiIt et AutoHotkey sont des langages de script permettant l’automatisation de tâches sous le système d’exploitation Windows.

Tutoriel AutoIt : https://www.autoitscript.fr/forum/viewforum.php?f=11

Tutoriel AutoHotkey : http://autohotkey.free.fr/docs/Tutorial.htm

Edited by Firebird
  • J'aime 1
Link to comment

Coucou !

Je me suis permis de déménager ta question ici, vu qu'elle diffère d'assez loin du sujet d'origine.

J'ai fait quelques petites recherches… :evil-plotting-raccoon: Voici le résultat :

Manuellement

Il est possible d'appliquer ce réglage depuis le Panneau de configuration (faire Windows+R taper « control » et valider), rubrique Horloge, langue et région, puis rubrique Langue, puis lien Paramètres avancés dans la colonne de gauche. Et enfin, lien Modifier les touches d'accès rapide de la barre de langue. Il y a deux choix, le premier est coché par défaut, et en choisissant le second, on obtient le comportement souhaité.

Mais on l'a vu, @papijo était bloqué à cet endroit à cause d'une restriction incongrue.
On va donc essayer par une autre méthode :

Depuis un fichier .reg

Après quelques recherches sur les modifications du registre que ce paramétrage implique, voici ce que ça modifie :

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Keyboard Layout]
"Attributes"=dword:00010000

Pour appliquer ce changement, ouvrir le bloc-notes (faire Windows+R taper « notepad » et valider), copier-coller le code ci-dessus, puis enregistrer le tout sous le nom « deverrmaj-touchemaj.reg » par exemple (l'important ici est d'enregistrer le fichier avec « .reg » à la fin). Puis exécuter le fichier .reg. Valider la modification.
Normalement, l'effet est immédiat.

@papijo est-ce que ça marche ?


PS : Antidote du premier fichier .reg !
Pour rétablir le comportement d'origine, voici le code à copier-coller :

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Keyboard Layout]
"Attributes"=dword:00000000

Donner au fichier texte le nom « deverrmaj-toucheverrmaj.reg » par exemple, puis le lancer.

  • J'aime 2
Link to comment

Trop fort @Le PoissonClown :x

enfin ça marche ! Du coup on voit toujours le message irritant "Des paramètres sont masqués etc..." mais on a accès au bouton "Options de la barre de langues" et de là aux "Paramètres de touches avancés".

Une fois de plus les crabes et les poissons réunis et tous les membres du navire ont vaincu Windows.:c_sunglasses:

Merci tout plein.

2018-07-25_16-08-36.jpg

2018-07-25_16-09-01.jpg

  • J'aime 2
Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...