Jump to content
Site Communauté

20auto-upgrades.merge-error dans le repertoir /etc/apt/apt.conf.d/


Recommended Posts

Bonjour,

je suis le petit nouveau sur le site.

Je n'arrive pas à me debarrasser de "20auto-upgrades.merge-error" dans le repertoir /etc/apt/apt.conf .d/ a été ignoré car il utilise une extension non valable.

A priori ca m'empeche de finaliser l'installation de open VPN de Cyberghost. 

20auto-upgrades.merge-error » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
W: http://build.openvpn.net/debian/openvpn/stable/dists/xenial/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details

Voila, je ne comprends pas tout d'ou ma bouteille à la mer!!

Je vous remercie d'avance

Link to comment

Bonjour,

Tu as un sacré chantier pas académique sur ta machine..., je m'explique

Selon ta capture d'écran, tu as Ubuntu Kinetic (version 22.10)

Toujours selon cette capture d'écran, ta distribution pointe pour OpenVPN vers une Debian stable/Xenial (version 16.04 d'Ubuntu) qui correspond à Debian stretch / sid...

Si tu veux de la stabilité avec une distribution Ubuntu, tu dois utiliser une version LTS (les deux dernières sont la 20.04 et la 22.04) qui sont maintenues cinq ans, les versions intermédiaires sont à proscrire sauf pour faire des tests. Malgré tout ce qui a été dit et tous les tutoriels qui existent, il n'est jamais bon de faire un upgrade de version/distribution avec une Ubuntu.

Je te propose plutôt de refaire une nouvelle installation propre d'une version LTS qui sont maintenues jusqu'en 2025 pour la 20.04 et 2027 pour la 22.04.

Autrement, mais sans aucune garantie, tu peux essayer de lancer cette commande dans le terminal pour voir ce que ça donne

sudo rm /etc/apt/apt.conf.d/20auto-upgrades.merge-error-old

Je pense que c'est un fichier obsolète d'une ancienne version, mais je n'ai aucune garantie que ça fonctionne malheureusement, ou si elle ne fonctionne pas, tu peux essayer cette autre commande :

sudo mv /etc/apt/apt.conf.d/20auto-upgrades.merge-error  /etc/apt

Edited by Tulburite
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...