meridian-shaft Jump to content
Forums

Automatisation de processus au démarrage du systè


Recommended Posts

Bonjour,

M'étant renseigné sur les protocoles internet, les serveurs DNS et leur application dans la vie privée, j'ai voulu faire en sorte d'améliorer ma confidentialité sur ma machine.

J'ai donc commencé par ajouter les DNS de Cloudfare (1.1.1.1 et 1.0.0.1) afin d'avoir une résolution des noms d'hôte plus rapide et respectueuse de la vie privée que celle de mon FAI.

J'ai ensuite appris que cette entreprise proposait une application qui permettait d'utiliser le protocole WARP et avoir une meilleure confidentialité. J'ai donc installé
warp-cli afin de le tester, et en parallèle le client gratuit de ProtonVPN, à des fins de tests et découverte.

Et ce matin, en allumant mon PC, plus d'accès à Internet ! Problème venant de mon PC car ma box est fonctionnelle et mes autres appareils y accèdent sans problème. Je me suis immédiatement rendu compte que cela était un problème de DNS, car je pouvais ping via Terminal des adresses IP mais non des noms de domaines (100% de perte de paquets). De plus, mon navigateur web affichait une erreur DNS_PROBE_POSSIBLE lorsque j'essayais d'accéder à des sites. J'ai donc commencé par vérifier le fonctionnement de warp-cli en l'activant, mettant le mode sur DNS uniquement, puis en essayant de supprimer la configuration WARP et d'en créer une autre : les opérations se passaient toujours très bien mais la résolution des noms de domaine restait impossible. J'ai donc supprimé 1.1.1.1 et 1.0.0.1 des serveurs DNS additionnels de ma connexion Ethernet via Network Manager, sans que cela change quoi que ce soit à mon problème (le mode IPV4 est l'adressage automatique via DHCP). J'ai essayé de modifier la connexion, mettre 192.168.1.1 en tant que serveur DNS (le DNS par défaut de ma box), toujours rien. Le client ProtonVPN ne tournait pas. J'ai même essayé de redémarrer ma box, débrancher-rebrancher mon câble Ethernet, ajouter des connexions Ethernet avec les paramètres par défaut, redémarrer les services Internet, supprimer toutes les connexions et recréer celle par défaut, rien !

 

Je n'en peux plus, j'ai essayé tous les trucs qui me sont passés par la tête (sauf balancer mon PC par la fenêtre :rolleyes:) et je n'ai toujours pas d'Internet !!!

 

Quelqu'un pourrait-t-il m'aider ? Merci d'avance.

 

Cordialement,

TechFox

 

Ma configuration logicielle :

	OS : Xubuntu 20.04 Focal (XFCE Desktop Environment)
	Navigateur Web : Brave 1.26.67
    
    
    
Le reste est sur mon profil.

 

Link to comment

Bonsoir et merci du retour !

Il y a 2 heures, zelandonii a dit :

Redshift est-il installé ?

Oui, j'ai installé Redshift (le logiciel pour réguler la température de son écran) afin de le tester mais je n'ai pas vu de différence notable puis je l'ai oublié. J'ai aussi le paquet redshift-gtk d'installé en plus du paquet redshift.

Que dois-je faire ?

Link to comment
Il y a 8 heures, zelandonii a dit :

Dis moi ce que tu trouves au niveau de la configuration de tes DNS en suivant ce tuto.

https://doc.ubuntu-fr.org/dns

J'ai suivi les instruction de la section 3 du document (problèmes connus) :

J'ai omis la sous-section 3.1 qui parlait de DNS local, ce qui n'est pas mon cas, et j'ai vidé le cache comme indiqué dans la sous-section 3.2, et j'ai affiché les statistiques que voici :

image.png.9d4e74549805da9c15e7d8ae06356120.png

 

Et voici la configuration actuelle de ma connexion :

capture2.png.0e6ea3f2010777bca4e25cf8d2a139a8.png

image.png.d34f90b3ff9b8f68e56939b49127e9aa.png

image.png.24b29a79d68b0b990fe74efeb736e4fb.png

image.png.d4e903552c43ef0e97da8f2ec6d62bfe.png

image.png.de7ddbcb95dadd9e16663bcfc6780582.png

image.png.3399b88dfa907df16a0de3fa8f1f936a.png

image.png.fa7bd759fabaa199f27609cdc56327f6.png

Link to comment
Il y a 19 heures, zelandonii a dit :

Ok, as-tu désinstallé warp-cli et Proton VPN ? Si ce n'est pas le cas, fais le.

J'ai supprimé complètement tous les paquets relatant à warp-cli et ProtonVPN.

Que dois-je faire ensuite ?

Link to comment
Il y a 6 heures, zelandonii a dit :

Ouvre le terminal et tape la commande suivante :

nano /etc/resolv.conf

Quels serveurs DNS sont notés ?

Il est indiqué :

nameserver 127.0.0.53
options edns0 trust-ad

 

Link to comment

Ouvre le terminal et tape la commande suivante :

sudo nano /etc/resolv.conf

Puis supprime les lignes déjà présentes et remplace les par celles-ci :

nameserver 1.1.1.1
nameserver 1.0.0.1

Ensuite fais CRTL + O > ENTREE puis quitte avec CTRL + X.

Pour finir, une fois le fichier fermé et revenu sur le terminal, tape la commande suivante :

sudo chattr +i /etc/resolv.conf

et clique sur ENTREE afin l'enregistrer.

En espérant que cela règle ton souci.

  • J'aime 1
Link to comment
Le 28/06/2021 à 19:05, zelandonii a dit :

Ouvre le terminal et tape la commande suivante :

sudo nano /etc/resolv.conf

Puis supprime les lignes déjà présentes et remplace les par celles-ci :

nameserver 1.1.1.1
nameserver 1.0.0.1

Ensuite fais CRTL + O > ENTREE puis quitte avec CTRL + X.

Pour finir, une fois le fichier fermé et revenu sur le terminal, tape la commande suivante :

sudo chattr +i /etc/resolv.conf

et clique sur ENTREE afin l'enregistrer.

En espérant que cela règle ton souci.

J'ai effectué toutes les modifications avec succès,  jusqu'à "chattr"

Le terminal me retourne :

chattr: Opération non supportée lors de la lecture des drapeaux sur /etc/resolv.conf

 

Link to comment
Il y a 16 heures, zelandonii a dit :

Tu n'aurais pas oublié d'espace ou mis un espace en trop ?

Sans cette commande, est-ce que ton problème de connexion est quand même résolu ? Après avoir redémarré ton PC.

J'ai essayé plusieurs fois de recommencer, j'ai veillé à supprimer les lignes déjà présentes (même les commentaires) et remplacer le tout par les deux nameserver et les IP, sans omettre ou ajouter d'espace. J'ai ensuite essayé de faire sans et avec la commande chattr (l'erreur persiste toujours). A chaque redémarrage le fichier /etc/resolv.conf se réinitialise et met un nameserver avec l'ip 127.0.0.53, et options edns0 trust-ad (comme au début).

Je suis un peu désespérer surtout que ce problème m'handicape pour faire des démarches et recherches en ligne...

Saurais-tu pourquoi le fichier se réinitialise-t-il ? Est-ce à cause de la commande chattr qui ne fonctionne pas ici ? Est-ce possible de faire cela d'une autre manière ?

Link to comment
Posted (edited)

Je vais continuer à chercher mais je te conseille en parallèle d'ouvrir un sujet sur le forum Ubuntu France.

Nous allons tester autre chose. Tape cette commande et redémarre ton PC.

sudo apt install --reinstall resolvconf

 

Edited by zelandonii
Link to comment
Il y a 6 heures, zelandonii a dit :

sudo apt install --reinstall resolvconf

;-; sans résolution DNS pas moyen de joindre les archives...

Le serveur Ubuntu FRance ne répond pas, je créerai mon topic après.

Merci pour ton aide précieuse, et si tu as des conseils, n'hésite pas !

Link to comment
Le 02/07/2021 à 22:18, zelandonii a dit :

Essaie ceci :

sudo apt remove --purge resolvconf
Puis
sudo apt install resolvconf

:c_fear: avec le précédent message concernant la réinstallation, la paquet a été supprimé et non réinstallé...

Donc je n'ai plus ce paquet...

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...