meridian-shaft Jump to content
Communauté

Walpo

Membres
  • Content Count

    24
  • Joined

  • Last visited

Everything posted by Walpo

  1. Merci beaucoup à toi Zelandonii, et aussi à Tulburite, pour le temps que vous avez consacré à ma question. J'ai découvert plein d'outils et de commandes intéressantes grâce à vous, et je peux vous assurer que je vais bien profiter de Linux désormais !
  2. Incroyable. Je suis parti dans toutes les directions pendant une semaine, j'ai exploré les notions de partitions, de disques, de démarrage, de Grub, de Boot Configuration Data... Ce ne sera pas inutile, je serai plus savant maintenant. Mais pour ce qui est de la résolution du problème mentionné en titre, j'avais la solution sous le nez. Dans le Setup Utility du démarrage de Windows (F10) => System Configuration => Boot Options => UEFI Boot Order, on accède à la liste des dispositifs qui seront lus dans cet ordre quand on allume l'ordinateur, et c'est là par exemple qu'on con
  3. Bonjour, C'est vraiment gentil de vouloir m'aider mais tu devrais faire attention quand tu donnes des commandes dont tu n'es pas sûr, je suis loin d'avoir assez de culture informatique pour me sortir d'affaire dans toutes les situations :-) Dans un message plus haut tu me conseillais de faire un << sudo grub-install /dev/sda >>, un peu plus tard tu me disais qu'en fait c'était << sudo grub-install /dev/sda1 >>, entre temps tu m'avais proposé << sudo grub-install --force /dev/sda >>, et là tu me préconises un << sudo fdisk /dev/sda >>
  4. Il y a l'air d'y avoir tout un tas de partitions inutiles, les deux sdb par exemple je m'en passerais bien, tout comme au moins l'espace non alloué du sda. On le voit sur la capture d'écran faite grâce à Gparted, qui est présent par défaut sous Ubuntu.
  5. Voici le rapport du fdisk -l : [email protected]:~$ sudo fdisk -l Disque /dev/loop0 : 1,99 GiB, 2109763584 octets, 4120632 secteurs Unités : secteur de 1 × 512 = 512 octets Taille de secteur (logique / physique) : 512 octets / 512 octets taille d'E/S (minimale / optimale) : 512 octets / 512 octets Disque /dev/loop1 : 55,48 MiB, 58159104 octets, 113592 secteurs Unités : secteur de 1 × 512 = 512 octets Taille de secteur (logique / physique) : 512 octets / 512 octets taille d'E/S (minimale / optimale) : 512 octets / 512 octets Disque /dev/loop2 : 218,102 MiB,
  6. Bonjour, désolé pour hier, je n'en pouvais plus de tourner en rond et de tester des outils, il fallait vraiment que je fasse un break. Tu dois avoir raison. Le rapport du boot-repair indique ceci : sdb1: __________________________________________________________________________ File system: vfat Boot sector type: SYSLINUX 6.03 Boot sector info: Syslinux looks at sector 16408 of /dev/sdb1 for its second stage. The integrity check of Syslinux failed. No errors found in the Boot Parameter Block. Operating
  7. Je ne sais pas, c'est quoi cette histoire de error: failed to get canonical path of `/cow' ? Ca donnait cette réponse déjà à la commande sudo update-grub, donc c'était pas lié à l'erreur. Ensuite je suis reparti lire le repair-boot, et il dit : => No boot loader is installed in the MBR of /dev/sda. => Syslinux MBR (5.00 and higher) is installed in the MBR of /dev/sdb. Il y a donc bien un business entre les deux formes, MBR et GPT. J'y ai passé toute la journée, et la moitié de la semaine, et là j'avoue que ce soir, je sature. C'était très gentil de m'avoir proposé des pi
  8. Je suis désolé, je m'en excuse, je n'ai pas envie de forcer le processus sans comprendre ce que je fais. Je veux bien télécharger Gparted ou je ne sais pas quoi d'autre, ou faire un fdisk, simplement pour repartir sur Linux il faut que je reboote sur la clé, je n'ai aucun moyen d'y accéder autrement. C'est d'ailleurs justement ça, le problème, sinon il n'y en aurait aucun...
  9. Bonsoir, Certains outils sont en effet très pratiques, je ne dis pas le contraire, mais là ce dont j'ai besoin c'est de trouver une explication ! Et dans le cas qui m'occupe, toutes les partitions sont saines, ce n'est pas ça le problème.
  10. Et voici une dernière incohérence. Dans les exemples que j'ai vus, le device du gestionnaire de démarrage et du chargeur de démarrage sont les mêmes, or ici ils sont différents :
  11. Mais via le gestionnnaire de disque => Propriétés => Matériel => Propriétés => Volumes, c'est une absence totale de données :
  12. Décidemment j'y comprends de moins en moins rien. Après téléchargement de AOMEI, et bien si, le disque est bien en GPT :
  13. Bonjour, et un grand merci pour ta réponse !!! En effet ça n'a pas marché, mais ça a fourni plein d'infos !!! D'abord, le compte-rendu : Ensuite Ubuntu permet de voir ce que Windows dissimule. Contrairement à ce que je croyais, j'ai un MBR, en plus d'un GPT. D'après l'article que j'ai lu, dans un MBR, le gestionnaire de démarrage de Windows est un fichier qui se trouve à l'adresse C:\bootmgr, alors que dans un EFI, c'est un fichier à l'adresse \EFI\Microsoft\Boot\bootmgfw.efi. J'ai bien un bootmgfw.efi mais à une autre adresse, C:\Windows\Boot\EFI, mais surtout j'ai a
  14. Pas de souci ! Je suis en train de potasser un article sur le BCDedit, et j'ai l'impression que mon ordinateur a d'abord été formaté en mode MBR avant de l'être en mode GPT. En tout cas j'ai des traces des deux systèmes dans mes fichiers. C'est peut-être pour ça qu'il ne s'y retrouve plus. Sauf si ça vient de mes tentatives successives avec des clés formatées une fois en MBR une fois en GPT, car si c'est le cas, le problème pré-existait.
  15. Il y a d'autres infos dans le rapport. Tu voudrais savoir quoi sur les partitions ?
  16. Le rapport du boot-repair (http://paste.ubuntu.com/p/43JdfZPqRy/) dit déjà beaucoup de choses. Notamment ces extraits : ============================ Boot Info After Repair ============================ => No boot loader is installed in the MBR of /dev/sda. => Syslinux MBR (5.00 and higher) is installed in the MBR of /dev/sdb. ================================ 2 OS detected ================================= OS#1: Ubuntu 20.04.2 LTS on sda5 OS#2: Windows 8 or 10 on sda3 ============================ Architecture/Host Info ============================ CPU architecture: 64
  17. La première fois, oui. Maintenant il me dit que Ubuntu est déjà installé et me demande si je veux l'écraser, ou utiliser tout le disque, ou une autre option à indiquer soi-même et dont je n'ai pas été voir ce que c'était. Je choisis évidemment de refaire l'installation sur l'ancien Ubuntu, pour ne pas perdre tous mes fichiers. S'il est au mauvais endroit, je reproduis l'erreur, mais si c'est une histoire de mauvais sda (j'avais par exemple le lecteur de CD sur la lettre E, au début, au lieu de D) il me faudrait avaler toute une année d'informatique hard ware pour savoir comment remédier à
  18. Merci beaucoup pour tes conseils et pour ton intérêt. Cependant la partition prévue pour Linux, je l'ai déjà supprimée et recréée après les premiers échecs, et ça n'a rien changé. Je ne pense pas que ce soit la bonne piste. Je vais plutôt essayer de comprendre ce que dit le rapport du Boot-repair.
  19. Je ne crois pas que la deuxième méthode apporte plus que la mise en oeuvre que j'ai faite du Boot-Repair, c'est simplement une autre façon, non ? Le rapport Pastebin du Boot-repair dit des choses, mais je ne sais pas les interpréter et encore moins comment les utiliser. J'ai l'impression que pour une raison que j'ignore Ubuntu ne s'est pas installé au bon endroit. J'ai mis la capture ci-dessous. Un des éléments qui m'étonne c'est que la partition de 50Go prévue pour Linux est libre à 100%.
  20. Je viens de lire. Le souci c'est que dans mon cas, tu peux le voir sur la photo d'écran plus haut, il n'y a pas du tout d'Ubuntu dans la liste du Boot Order de l'UEFI. C'est comme s'il n'était pas là, alors qu'à chaque fois, encore cette fois-ci quand j'ai lancé le Boot-Repair, quand je reviens à Windows il y a le décalage de deux heures qui se produit toujours entre Linux et Windows tant qu'on n'a pas accordé les horloges internes. Ce qui veut bien dire qu'il est là, Ubuntu. Simplement il est invisible, inaccessible.
  21. Non je n'avais pas vu ce tuto, je vais aller le lire. C'est ici dans le forum que quelqu'un évoquait Boot-Repair, et après, là où j'ai cherché, il y avait le mode d'emploi en même temps que le lien pour télécharger. J'ai un seul disque.
  22. Bonjour Zelandonii, Merci beaucoup pour la réponse ! Alors en effet, quand je démarre, le PC lance directement Windows. J'avoue ne pas avoir vérifié l'intégrité du fichier ISO de Ubuntu, qu'il me semble avoir récupéré sur leur site, ni avoir essayé avec une autre clé, mais tout se déroule très normalement, paramètres de langue, de lieu, etc, puis suppression des fichiers inutiles (je demande la version minimale) pendant de longues dizaines de minutes, jusqu'à la fin, où il m'est demandé de redémarrer. Sauf qu'ensuite Ubuntu est invisible, comme on peut le constater sur la photo de la conf
  23. Dans la configuration du Boot il y a des paramètres qui me posent question et qui expliquent peut-être le problème : Le Secure Boot c'est moi qui l'ai mis en <disabled>, donc ça va, mais "Internal Network Adapter Boot" et "Legacy Support" en <disabled>, est-ce normal ? Merci à toute personne qui voudra bien répondre !
  24. Bonjour, Je viens de réinstaller un dual boot Windows 10 / Ubuntu sur mon ordinateur grâce à l'excellent tuto du Crabeinfo, comme plusieurs fois déjà précédemment. Tout se passe normalement sauf qu'à la fin, quand je relance, Ubuntu n'est visible nulle part. En comparant les tailles, 4Go ont l'air de manquer à la partition de C, mais la partition principale créée pour Ubuntu est libre à 100%, comme si rien n'y avait été ajouté. Pareil dans l'espace de configuration de l'UEFI, le Secure Boot est bien désactivé, mais aucune mention de Ubuntu dans le Legacy Boot Order. J'ai refait l'opé
×
×
  • Create New...