Aller au contenu
PhilR

Win10 2004 impossible à installer - Pb UEFI

Messages recommandés

Bonjour,

Je rencontre le problème suivant lors de la tentative de mise à jour de Windows 10 release 2004. En effet j'ai le message suivant (assez sibyllin, mais en cherchant on trouve) :

        -  Impossible d'installer Windows car cet ordinateur présente une disposition de disque non prise en charge pour le microprogramme UEFI

J'ai déjà procédé à un certaines nombres de vérification :

- Effectivement mon disque système est en MBR (pas en GPT, et c'est un pb)

- Si j'essaye de passer ce disque système en GPT via l'utilitaire MBR2GPT, j'ai le message d'erreur suivant ( en exécutant la cmd mbr2gpt /validate /disk:6 /allowfullOS )

      MBR2GPT: Attempting to validate disk 6
      MBR2GPT: Retrieving layout of disk
      MBR2GPT: Validating layout, disk sector size is: 512 bytes
       Cannot find OS partition(s) for disk 6

Ce qui est assez surprenant car je vois bien le disque système via le gestionnaire de disque marqué disk6 .... en contrôlant via Diskpart (on ne sait jamais) j'ai bien  (cmd : DISKPART> list disk)

     N° disque  Statut         Taille   Libre    Dyn  GPT
      ---------  -------------  -------  -------  ---  ---
      Disque 0    En ligne       3726 G octets  1024 K octets        *
      Disque 1    En ligne       1863 G octets  1024 K octets
      Disque 2    En ligne       1863 G octets  2048 K octets
     Disque 3    En ligne       2794 G octets      0 octets        *
     Disque 4    En ligne        931 G octets      0 octets
     Disque 5    En ligne       1863 G octets  2048 K octets   *
     Disque 6    En ligne        238 G octets   257 M octets
     Disque 7    En ligne        931 G octets      0 octets

J'ai bien disk6 comme disque système (SSD de 256 Go)

Bref je comprends que j'ai un GROS problème, et pourtant ce PC a été régulièrement mis à jour depuis win7 sans pb particulier.

Il faut donc que je réussisse à passer mon disque système de MBR à UEFI (le BIOS du PC est bien UEFI - il fait les 2 en fait - CM ASUS ROG MAximus VIII de fin 2016). Et là je sèche un peu, si vous avez des idées, des pistes de réflexion, je suis preneur. Merci d'avance. 

PS: J'essaye d'éviter la réinstallation complète de Win10, j'ai beaucoup de logiciels installés et ce serait des heures à reconstruire le PC (installation + paramètrages - les noter avant, les refaire après).

PS2: Pas de partition UEFI, ni MSR présente sur le HDD système (pas forcément anormal).

Modifié par PhilR

Partager ce message


Lien à poster

bonjour @calisto06,

Merci du rapide retour. MPW installé, tu veux une copie de l'écran qui visualise l'ensemble des disques ou bien que je raconte ce que j'y trouve ?

Partager ce message


Lien à poster
il y a 17 minutes, PhilR a dit :

une copie de l'écran

Une capture écran ou on voit le détail des partitions des différents disques

Partager ce message


Lien à poster

Ok, voici...

 

PS: Beaucoup de disques data ..

image.thumb.png.f797691b3a2eee79b3901173f8890eeb.png

Modifié par PhilR

Partager ce message


Lien à poster

Ton disque 6 est un disque dynamique ...pourquoi ? C'est certainement l'origine du blocage

Par ailleurs quels systèmes as tu installé sur quels disques car je vois des partitions systèmes ça et là ....

Ex : sur le disque 1 en GPT il y a une petite partition Autre de 16Mo qui peut correspondre à une installation Windows en UEFI ...ou autre ..et une autre partition logique de données sur le disque 2 ..pourquoi ?

Sur le 7 en MBR on a une partition Notée Système active ..puis un espace non alloué et une partition Windows pro C qui doit être un système w10

Donc j'imagine que tu as Windows 10 sur 7 en MBR : ce que je ne comprend pas c'est la taille de la partition système de 58 g

Regarde les différents partitionnements https://lecrabeinfo.net/differences-mbr-gpt-tables-de-partitionnement.html

MBR (on peut avoir des variantes mais là ce sont les valeurs par défaut lors d'une installation Windows )

windows-10-bios-mbr-layout-partitions-disque-5a56340e3f659.png

La partition réservée système fait 500 Mo normalement et il n'y a pas d'espace non alloué entre C et cette partition et la partition recovery fait environ 450 Mo

Si tu fais explorer qu'y a t-il dans cette partition de 58.4g ?

C'est assez fouillis ....il y a du MBR qui côtoie du GPT ....ça serait pas mal homogénéiser un peu tout ça (sauf contre indication)

Je vais demander à @Mreve de me donner ses impressions (le partitionnement c'est assez son rayon ) 

Modifié par calisto06

Partager ce message


Lien à poster

Merci @calisto06, pour cette première analyse. Ci-après quelques explications :

- Disque dynamique, je ne me souviens plus, car créé il y a assez longtemps pour gérer 2 partition sur un disque physique de 4Go, mais ce n'était peut-être pas la bonne solution. Sinon pas de raison particulière pour garder cette disposition, par contre c'est bien plein, il faut pouvoir sauvegarder et recopier une fois la situation rétablie.

- Disque 1 : je découvre cette partition avec le logiciel, on ne la voit pas avec le gestionnaire Win par défaut

- Disque 7, c'est bien mon disque système, la partition de 58Mo correspond à une installation Win7 que j'avais conservée un temps pour un dual boot. Ne me sers plus a rien aujourd'hui, mais toujours hésité à l'effacer purement et simplement de peut de "casser" quelque chose)

Je n'ai pas de recovery sur ce système, jamais eu en fait (on vient de Win7).

Il n'y a pas de contre indication à passer les disques data qui sont majoritairement en MBR en GPT, juste jamais prêté attention à la chose (pas important pour les datas a priori - tu peux me dire le contraire , c'est plus une remarque qu'autre chose).

Merci pour le lien, j'irai voir.

Partager ce message


Lien à poster

Bonjour @PhilR et bienvenue sur le forum.

On va pas se le cacher, c'est le gros bazar sur ton PC. Tu as beaucoup beaucoup trop de partitions inutiles et ça c'est pas une bonne chose (Pourquoi ?)

Si tu veux passer ton disque en GPT (pour booter en mode UEFI), MBR2GPT se chargera de créer une partition ESP/EFI.

Je considère que ta carte mère a bien un firmware UEFI mais vérifie si tu n'es pas sûr (en allant voir la doc de ta carte mère ou en allant directement vérifier dans le firmware)

Regardons un peu en détail le disque qui nous intéresse (le Samsung 840 Pro) :

  • Partition N (Flags : Actif + Sytème)
  • Partition C (Flags : Démarrage)

La terminologie utilisée par Microsoft est stupide car le flag démarrage ne veut pas dire que cette partition contient le bootloader (logiciel qui lance un OS) mais que c'est sur cette partition que ce trouve l'OS en lui-même. C'est la partition système qui contient le bootloader.

Actif indique simplement à l'UEFI/BIOS que la partition est bootable. Une partition active n'a donc de sens que si elle a aussi l'étiquette système


Normalement cette partition N devrait correspondre à la partition réservée système. Je ne sais pas trop ce que tu as traficoté là mais ce n'est pas le cas sur ton PC.

Est-ce que tu peux mettre en pièce jointe le fichier log setupact.log (%windir%/setupact.log) ? On va essayer de voir pourquoi ça coince. Il y a plusieurs causes possibles mais la plus probable à mon avis c'est parce que tu boot en mode UEFI legacy et MBR2GPT

Pense à faire une sauvegarde de ton disque par précaution avant de commencer les manipulations.

 

Tu peux déjà essayer de copier le BCD (Boot Configuration Data) à un endroit où MBR2GPT pourra le trouver.

bcdboot c:\Windows /f bios /s c:

Réessaie ensuite MBR2GPT

mbr2gpt /convert /allowFullOS

Si ça marche, pense à bien à changer l'option Boot mode de l'UEFI à UEFI (et non plus en Legacy ou CMS) pour que Windows puisse démarrer.

 

Modifié par Mreve

Partager ce message


Lien à poster

Bonjour @Mreve,

Merci d'avance pour l'aide. Pour commencer le fichier demandé en PJ.

Sinon, ce n'est pas une volonté de'avoir un disque système partitionné, c'était au départ un dual boot, avec Win7 en N: et Win8 en C:  (nécessaire pendant une période de transition pour conserver un soft qui n'était pas encore 100% compatible win8). Après je ne m'en suis pas vraiment préoccupé, les updates s'effectuant sans problème y compris le passage Win8 vers Win10.

Clairement si je peux me débarrasser de cette partition N: et n'avoir qu'un disque système logique = disque physique, ça me conviendrai.

Les autres disques sont des disques data, partitionnés pour des raisons de nommage et de gestion des sauvegardes, c'était valable à l'époque, aujourd'hui c'est beaucoup plus discutable j'en conviens. (Il y a un NAS lié par Wi-Fi qui réplique certains disques en temps réels et reçoit les sauvegardes des autres - incrémentales journalière, full hebdo).

J'attends ton avis sur le fichier envoyé (j'ai regardé, je comprends que MBR2GPT est trompé et considère le mauvais "disque" pour chercher le système).

PS: Carte mère ASUS ROG Maximus VIII (fin 2016), BIOS American trends, actuellement boote avec le CSM activé (logique avec une disque système en MBR).

PS2: Je vais faire un clone du disque système en attendant.

setupact.log

Partager ce message


Lien à poster

Bonsoir,

Quelques nouvelles ...

Clone du disque système fait (Acronis)

Messages après avoir exécuté les deux lignes de commandes, échec de la commande mbr2gpt (Cf. fichiers joint). image.png.806b9e183ae225fdeab87fd7b9bec117.png

image.png.f9a61c673e948a69b73eb6d88d912d25.png

 

PS: vu de ma fenêtre le pb demeure, il semble que la partition bootable est la 1,  donc N:

setupact.log

Partager ce message


Lien à poster

MBR2GPT ne se trompe pas de partition, il y a juste un problème avec la BCD.

===================PARTITION===============================
Number: 1
Type: 7
Boot: Yes
Recognized: Yes
Style: 0
Offset: 1048576
Length: 62744690688
Volume: \\?\Volume{0020451d-11e0-11e0-9283-806e6f6e6963}\
Drive: N:\
NT Path: \Device\HardDisk6\Partition1
===================PARTITION===============================
Number: 2
Type: 7
Boot: No
Recognized: Yes
Style: 0
Offset: 63015223296
Length: 193044938752
Volume: \\?\Volume{0020451e-11e0-11e0-9283-806e6f6e6963}\
Drive: C:\
NT Path: \Device\HardDisk6\Partition2
===========================================================
ESP partition size will be 104857600
MBR2GPT: Validating layout, disk sector size is: 512 bytes
BCD: Opening store. Flags: 0x0
BCD: Store path: "\??\GLOBALROOT\device\harddisk6\partition1\Boot\BCD"
BCD: Failed to load hive into key BCD00000000 from \??\GLOBALROOT\device\harddisk6\partition1\Boot\BCD. Status: c000000f
BCD: BcdOpenStore: Failed to add store from file \??\GLOBALROOT\device\harddisk6\partition1\Boot\BCD. StoreFlags: 0x0 Status: c000000f
FindOSPartitions: Cannot open BCD for boot volume. Error: 0xC000000F

Quel est le résultat de :

bcdedit /enum All > bcd.txt

Il te suffit de joindre le fichier bcd.txt qui sera créé

Il se peut aussi que ça retourne une erreur. Donne bien le message d'erreur dans ce cas.

Modifié par Mreve

Partager ce message


Lien à poster
Gestionnaire de démarrage Windows
---------------------------------
identificateur          {bootmgr}
device                  partition=N:
path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
description             Windows Boot Manager
locale                  fr-fr
inherit                 {globalsettings}
default                 {current}
resumeobject            {854013d8-eb7f-11e9-8a03-ebecf50d3396}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Ok. Donc le PC utilise quand même le bootloader UEFI, c'est normal j'aurais dû m'en douter.

Bon je vais pas te mentir, je ne suis pas 100% sûr de moi mais comme tu as cloné ton disque, ça ne coûte rien d'essayer.

Théoriquement ça devrait marcher.
 

1) Même manip que précédemment sauf qu'on copie aussi la BCD et le bootloader UEFI sur C:

bcdboot c:\Windows /f ALL /s c:


2) Ensuite on marque la partition C comme bootable (flag active)

DISKPART> list partition

Normalement C devrait correspondre à la partition 1 et N à la partition 2 mais vérifie dans le doute :

DISKPART> select partition 1

DISKPART> active

DISKPART> select partition 0

DISKPART> unactive

DISKPART>exit


3) Réessaie MBR2GPT

mbr2gpt /convert /allowFullOS

Mets en pièce jointe le log (%windir%/setupact.log) au cas où

Si ça marche, tu devrais pouvoir redémarrer ton PC en mode UEFI ! :c_magic:

Si Windows ne démarre plus :
-
Boot depuis une clef bootable Windows,
- Ouvre l'invité de commande (en appuyant sur Maj + F10)  (aide)
- Réactive la partition N et "désactive" la partition C avec diskpart

Il te faudra sans doute repasser ton firmware en mode Legacy/CMS

Modifié par Mreve

Partager ce message


Lien à poster

Processus en cours ...

état des partitions après les changements effectués (reste MBR2GPT à exécuter).

image.thumb.png.678e940cbaca30ca2a93faf1f6456591.png

Partager ce message


Lien à poster

Bon, on avance, mais pas jusqu'au bout, /validate répond OK, mais à l'exécution ça ne passe pas jusqu'au bout. Cf. Fichiers joints. image.png.f0d9081674fdf8f908d2ad536adf61ff.png

setupact.log

Partager ce message


Lien à poster

News :

L'erreur est une erreur connue de Microsoft (le système essaie d'allouer pour la partition EFI la totalité du disque, ce qui ne marche évidemment pas). Donc, j'ai créé une partition EFI de 100Mo, puis relancer le processus avec MBR2GPT. Cf. Résultat ci-dessous. A priori c'est ok ..

image.thumb.png.3c0aa0280c494b439e608af4b88e7c12.png

Partager ce message


Lien à poster

On voit, en utilisant Macrium, que le disque système est bien désormais de type GPT. (Cf. Copie écran).

PS: J'ai détruit la partition EFI que j'avais créée à l'étape précédente, Windows m'en ayant créée une toute propre avec les bons attributs. Reste plus qu'à lancé l'update de windows pour voir si tout se déroule correctement.

image.thumb.png.fa63ea67994180358df617d4ca13d30b.png

Partager ce message


Lien à poster

Essayé de faire la mise à jour, le résultat n'est pas probant, Cf. capture d'écran.

J'ai regardé diverses solutions (fais l'arrêt du service Win Update, effacer les fichiers temporaires, relancer le service Win Update), bis repetita, mème erreur.  Là je seiche un peu ...

image.png.7b3683e97d7f49bb285ea0a86ae7f794.png

Partager ce message


Lien à poster

(Je suis actuellement en vacance à la montagne. Je ne te garantis donc pas de pouvoir rapidement à chaque fois)

Pas de joli formatage ni de jolies explications cette fois, c'est une réponse rapide depuis mon téléphone :

Bon c'est bien. Ça avance ! Belle initiative pour la partition EFI :)

0x8007002 est un code d'erreur classique. Il y a plusieurs causes possibles mais au vu des manipulations précédentes je pense que tu devrais plutôt essayer de faire un :

SFC /scannow (depuis l'invité de commande en mode admin)

net stop wuauserv (ça stoppe Windows Update)

Supprimer C:\Windows\SoftwareDistribution

qui est un dossier stockant les MAJ.

net start wuauserv

Si ça ne fonctionne pas, le plus simple c'est de faire la mise à niveau directement depuis un support d'installation Windows (clef bootable). C'est plus fiable que Windows Update.

Modifié par Mreve
  • J'aime 1

Partager ce message


Lien à poster

Attention si tu fais la mise à niveau depuis un iso 2004 déconnecte le pc d'internet . 

 

Partager ce message


Lien à poster

@calisto06
 

Ça me fait penser, en case de mise à niveau, je pense que tous les fichiers de MAJ sont stockés dans un dossier caché C:\Windows~BT. 

Si c'est bien le cas, supprimer C:\SoftwareDistribution n'a pas vraiment d'intérêt. D'ailleurs on passer par le support d'installation devrait outrepasser C:\Windows~BT

Tu confirmes ? Je ne suis plus trop à jour sur ces choses. Il y a Windows~WS aussi dans certains cas mais je ne me rapelle plus de la différence.

Modifié par Mreve

Partager ce message


Lien à poster

perso je fais un nettoyage des fichiers systèmes comme décrit ici

 

Modifié par calisto06

Partager ce message


Lien à poster
il y a 32 minutes, Mreve a dit :

mais je ne me rappelle plus de la différence.

https://social.technet.microsoft.com/Forums/en-US/21d4e170-47a0-4a9f-a820-7814d24c377b/windowsbt-and-windowsws?forum=win10itprogeneral

Ce sont des fichiers de configuration et temporaires , si la migration a échoué inutile de les garder 

On peut les conserver pour un retour à la version précédente au cas ou (dans ce cas inutile de les garder) 

Partager ce message


Lien à poster
il y a 55 minutes, Mreve a dit :

en vacance à la montagne

Et t'as eu 38°C ???? :wacko:

Partager ce message


Lien à poster

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • Derniers messages

    • bonjour, quand vous parlez de réinstallation, vous voulez dire suppression des partitions et re création des partitions ... votre bug en ce moment court sur le forum... on en parle justement avec @Mreve qui a fait une intervention hier sur un problème similaire d’icône qui font un peut les sauvages citation :  
    • yop là ... @Indyka il y a deux écoles .. Ceux qui trouve que c'est pas bon. D'autres qui trouve que cela n'est pas pire qu'un HDD. Je suis de la deuxième école et sur un MSI pc portable avec 2 SSD de 120go qui comptabilise 4 ans maintenant de loyaux service, je réalise des défragmentations sur ses deux SSD sans aucun problème de puis leur naissance.. il est clair qu'il ne faut pas le faire toute les semaines. D’ailleurs sur aucun SSD et ni aucun HDD il ne faut faire cela 1x/sem. Une fois par mois est bien suffisant. J'ai bien entendu un moment donner tenter de voir ce que cela allait faire si je prenait la 1er école donc de ne pas défragmenter ce SSD. Et bien je t'assure que les trou qui se forme dans le SSD est tout simplement astronomique! Celui qui dit ouaiii il s'optimise seul, il comble ses trou lui même.. Beh a mon avis il a jamais été voir ce qui se passait dans ce SSD après 3 mois de non défragmentation. Non cela n'est pas si mauvais qu'ont peut l'entendre sur le net.. Il ne faut juste pas en abusé. je le fait une fois par mois si j'y pense ... Sur un Alien M17 qui est composé de 2 SSD et encore une fois sans aucun souci... question : quelle est ta fréquence de défragmentation ?  
    • Salut la crabosphère,  J'espère que vous allez bien en ces temps de crise sanitaire. J'ai une petite question pour vous,  Sommes nous bien d'accord sur le fait de défragmenter un SSD n'est pas bon du tout ?   Je vous pose cette question car je viens de découvrir une option de Windows 10 activé de base qui planifierais la défragmentation des disques de stockage ( SSD ou HDD ).  https://cdn.discordapp.com/attachments/558693933723680778/739979370332029008/unknown.png   Du coup, je vous pose une deuxième question : Est ce qu'une méthode de défragmentation existe pour optimiser les SSD ?    PS : Je précise que j'ai désactiver l'option et je l'ai planifié touts les mois au cas où ( Oui je suis parano )
    • Bonjour,  Mon fixlist est toujours disponible, mais inutile de le passer maintenant. Il faut moins de temps pour passer un correctif ou poster un message expliquant ton retard qu'il ne m'en faut pour analyser tes rapports, préparer un correctif et te donner des conseils. De plus, nous sommes bénévoles, et avons aussi un métier prenant, pour la plupart d'entre nous, en témoigne l'heure de ma réponse. Bref, le minimum est que le demandeur d'aide s'implique dans le dépannage, et manifeste de la considération pour le helper, malgré/surtout en raison de la gratuité de son intervention. Cette désinfection est terminée et tes BSOD ne proviennent pas d'une infection. Je vois que tu as conservé Chrome, navigateur gourmand, remplaçable par Edge Chromium comme je te l'ai déjà indiqué. => Mes conseils aujourd'hui Les plantages sur ntoskrnl.exe et ntdll.sys. sont souvent causés par des pilotes. Mais on ne peut pas exclure un souci matériel. Tout d'abord, je te conseille de désinstaller Nvidia GeForce Experience, logiciel connu pour provoquer des écrans bleus, puis de redémarrer ton PC. Puis réinstalle les pilotes de ton PC depuis le site du constructeur, Asus Carte mère: ASUSTeK COMPUTER INC. Z87-A. Ensuite, si tu as encore des écrans bleus, ouvre un nouveau sujet sur le forum Windows. Bonne continuation.
    • Bonjours je me présente ''fouraide''   un québécois , canadien , sherbrookois :) un passionné des produits windows , bien que  un ptit penchant pour linux .      
    • Bonjour @gege12 vide le cache de Windows update à l'aide du script du tutoriel  https://www.vulgarisation-informatique.com/article-767--reinitialiser-windows-update.php Récupère la mise  à jour https://www.catalog.update.microsoft.com/Search.aspx?q=KB4565483 et installe la .
  • Contributeurs populaires

  • L'article du moment

  • Qui est en ligne (Afficher la liste complète)

×
×
  • Créer...