meridian-shaft Jump to content
Forums

Archer C7v4 : pas d'accès à l'interface web


Recommended Posts

Bonjour,

J'ai le dongle Huawei Model E3372h-607 et le Archer c7 v4

Initialement, le dongle ne s'allumait pas de façon continue quand connecté sur l'Archer. Mais il s'allumait de façon continue quand connecté sur le PC.

initialement, je n'avais pas d'accès à la page web de l'archer (192.168.1.1) mais j'avais un accès ssh nickel.

J'ai fait la mise à jour du dongle grâce au crabe (version finale 22.323.01.00.00) et accès au réseau via la carte SIM SFR quand connecté sur le PC

Je voudrais faire l'update vers OpenWRT mais je n'ai pas d'accès à la page 192.168.1.1, la lumière du dongle clignote et aucun WIFI n'est disponible. Seul SSH fonctionne mais la commande

lsusb produit une réponse désagréable : unable to initialize libusb: -99

Quelle serait la commande pour démarrer le serveur web de l'Archer ?

Link to comment

J'ai l'impression que tu n'as pas installé Luci, qui est justement cette interface graphique web (il y a des routeurs sur lesquels le firmware OpenWrt n'a pas ce programme installé automatiquement).

Pour cela tu dois te connecter au routeur en SSH (avec le logiciel Putty par exemple) : sur l'interface sur rentre l'IP du routeur, tu vérifie que tu a bien coché SSH et tu te connectes. Tu vas atterrir sur une interface en ligne de commande. Il va te demander ton login qui sera surement "root", puis s'il te demande ton mot de passe essaie avec "root".

Entre les commandes suivantes :

opkg update

opkg install luci-ssl

Dis moi si tu vois des erreurs.

Normalement après ça, si tu vas dans ton navigateur sur l'adresse IP du routeur, tu devrais avoir l'interface graphique.

L'autre problème qu'il peut se poser c'est que ton routeur pourrait avoir la même IP que ta box opérateur et donc créer un conflit IP. Il faudrait que tu vérifies ça.

Link to comment

Merci, installation faite et c'est bcp mieux ! (mais le look des pages web n'est pas le même que sur LeCrabe.

Peut-être une info à ajouter dans la page concernant Archer c7 pour l'install de Luci ?

Merci en tout cas.

En revanche, la réponse à la commande "lsusb" est toujours la même : unable to initialize libusb: -99

Une idée ?

Link to comment

Alors moi personnellement, j'ai configuré mon E3372h en Stick sur un routeur OpenWrt, en le configurant en NCM.

  1. Si tu veux rester en firmware HiLink, je te conseille plutôt le firmware d'origine HiLink (22.180.05.00.00)
  2. Si tu essaye de configurer ta clé 4G en firmware HiLink sur ton routeur OpenWrt, est ce que tu utilise bien le protocole RNDIS : cf cette partie du tuto : https://lecrabeinfo.net/installer-firmware-openwrt-sur-routeur-wi-fi.html#protocole-rndis
  3. Si cela ne fonctionne pas, je pense qu'il faudra que tu essaye de passer en firmware Stick, puis configurer le multimode pour OpenWrt, puis l'installer sur ton routeur via le protocole NCM
Link to comment

En fait, j'essaye effectivement d'utiliser le protocole RNDIS et tout va bien jusqu'au point n°5 où la commande lsusb ne fait pas ce qui est attendu.

Et je pense que ce problème n'a rien à voir avec le type de dongle USB présent : j'ai fait la manip avec une clé mémoire USB et la même réponse est arrivée.

Je pensais que l’accès à l'interface web permettrait d'avoir la main sur le fonctionnement de l'USB mais non, c'est seulement le réseau.

Pour l'instant je vais laisser cela tranquille et je reprendrai ce sujet dans une semaine.

Merci pour le support.

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...