meridian-shaft Jump to content
Forums

NAS connection Inaccessible


Solved

Recommended Posts

Bonsoir, je viens vers vous car j'ai un sérieux soucis sur un NAS VHS4 de Ve-Hotech société qui a malheureusement disparu corps et bien.

Je viens de rentrer d'un cours séjour et je n'ai plus accès au NAS avec le réseaux, celui-ci fonctionné très bien jusqu'à présent mais hier impossible de me connecter dessus surtout que j'ai eu des alertes sur le stockage de mes fichiers avant ce problème.

Sur l'explorateur je le voie mais dès que j'essaye de me connecter dessus il m'indique que je n'ai pas les droits nécessaires (voir fichier joint).

Pourriez vous m'indiquer ce que je peux faire afin de remédier a cela et récupérer les données dessus.

Explorateur.png

Connection NAS.png

Link to comment

Je  rajoute que ce NAS à une fonction propriétaire (enfin je suppose car il y a une clé USB connecté sur la carte mère) qui a l'air (pas testé) crypté. Je pense que si je retire cette clé j'aurais surement un NAS sans logiciel mais simplement avec des disques dedans (donc possibilité de remettre une appli pour en refaire un), Cependant si j'enlève cette clé les données seront définitivement perdu se qui serait à éviter bien entendu. Enfin pour le moment je ne suis pas arrivée à ce stade de compromis ^^.

Link to comment

Bonsoir, désolé pour la réponse tardive

Il y a 13 heures, Longaripa a dit :

Re

Est-ce que vous pouvez le pinger ? 
Dans une invite de commande : ping < add IP du NAS> 

par exemple : ping 192.168.0.10

Si oui, ensuite, dans un navigateur

http://192.168.0.10

( adresse du NAS)

donc pour le ping et le web je mets les imprimes plus explicite qu'une réponse évasive. Je crois a mon avis que je pourrais pas faire grand chose, je vais attendre quelques réponses sur le sujet ensuite je verrai en proposant une solution espérant qu'elle me sorte de ce pétrin.

Adresse Web.png

Ping sur NAS.png

Link to comment

Bonjour 

Il est bien joignable, mais refuse les connexions.

Avez vous essayé de l'éteindre, débrancher le courant, puis le rallumer ? 

Quels sont les voyants allumés, clignotants ou autres ? *

1 hour ago, Toto61 said:

Salut,

Puis-je me permettre de me joindre à la discussion ?

Bien sur .... 

Link to comment

Merci,

Le 20/09/2021 à 17:04, Mc82 a dit :

j'ai eu des alertes sur le stockage de mes fichiers avant ce problème

Cette remarque initiale m'interpelle, et sent un problème de disque. Donc, avant de continuer :

  • peux-tu nous joindre une de ces alertes
  • peux tu nous indiquer l'état des différentes LED en face avant, notamment, celles qui concernent les disques et le bouton Power
  • peux tu nous indiquer le nombre de disques présent, ainsi que le type de RAID utilisé (0/1/5 ou éventuellement JBOD)

D'autre part, peux tu nous indiquer exactement la référence de la clé USB connecté, car, sauf spécificité, elle ne devrait pas avoir d'impact sur le contenu des disques.

Bien évidemment à ce stade, on ne touche pas du tout aux disques (ni retrait, ni réinsert), avec le NAS allumé...

Enfin, question complémentaire : l'accès SSH est-il disponible (activé volontairement au préalable)

Edited by Toto61
Link to comment
Il y a 9 heures, Longaripa a dit :

Bonjour 

Il est bien joignable, mais refuse les connexions.

Avez vous essayé de l'éteindre, débrancher le courant, puis le rallumer ? 

Quels sont les voyants allumés, clignotants ou autres ? *

Slt, merci pour les réponses rapide

pour les voyants façade: démarrage alimentation (bleue), accès disque dur (rouge fixe et clignotant après que les disques soient en action), accès internet au (vert fixe)

voyant disque dur: vert clignotant (indiquant une recherche quelconque) et voyant alimentation bleue fixe.

Il y a 7 heures, Toto61 a dit :

Merci,

Cette remarque initiale m'interpelle, et sent un problème de disque. Donc, avant de continuer :

  • peux-tu nous joindre une de ces alertes
  • peux tu nous indiquer l'état des différentes LED en face avant, notamment, celles qui concernent les disques et le bouton Power
  • peux tu nous indiquer le nombre de disques présent, ainsi que le type de RAID utilisé (0/1/5 ou éventuellement JBOD)

D'autre part, peux tu nous indiquer exactement la référence de la clé USB connecté, car, sauf spécificité, elle ne devrait pas avoir d'impact sur le contenu des disques.

Bien évidemment à ce stade, on ne touche pas du tout aux disques (ni retrait, ni réinsert), avec le NAS allumé...

Enfin, question complémentaire : l'accès SSH est-il disponible (activé volontairement au préalable)

Bonjour Toto61 et merci pour ta participation.

Je vais faire mieux lol, devant vous donnez une réponse, je viens de rebrancher et réallumer le NAS et celui-ci viens de démarrer comme si de rien n'était. J'en profite donc pour regarder l'état de mes disques (4 en raid5) et je viens de voir qu'un des disques n'est pas pris en compte dans mon raid (je mets une copie écran). Concernant l'alerte cela tombe bien car il vient de m'en faire une donc idem copie écran (je suppose que l'un ne va pas sans l'autre). Donc pour le moment je viens de relancer une réintégration de la mappe afin qu'il soit pris en compte.

Ce que je ne comprend ce n'est pas la première fois que j'ai ce problème mais j'ai toujours eu accès au système et la rien d'où mon étonnement et ma demande d'intervention surtout qu'il y a pas mal de données dessus. Pour l'accès au SSH bonne question (que je me suis jamais posé) il faudra (une fois la réintégration effectué) que je regarde ou elle se trouve mais il me semble qu'il y a longtemps je l'avais mis en place (à contrôler). Pour l'USB connecté dans la partie ordi je mets une photo plus explicite, si celle ci ne compromets pas le stockage mais simplement le système logiciel je verrai bien pour le remplacer par autre chose comme appli, le seul soucis je ne voudrais pas compromettre mes données car je pense qu'elle sont faite de telles façon avec ce logiciel et la mise en place d'un autre changerait les l'emplacement des données voir demanderai un formatage disque à la mise en place (la je me suis peut être mal expliqué lol).

Voila, si pour le moment vous pouvez me dire pourquoi le soucis (peut-être disque principal qui a causé l'erreur) et dans un autre cas si je change d'appli à quoi m'attendre.

Désolé pour ce paragraphe un peu long.

Mc82

NAS Acce Disque.png

Alerte Ve-Hotech.png

IMG_20210922_201749_HDR.png

IMG_20210922_201832.png

Link to comment

Je te confirme une chose tout de suite : si tu remplaces le firmware / logiciel de ton NAS, tu devras reformater l'intégralité de tes disques, même s'il s'agit d'un RAID5 standard. Donc, prévoir d'externaliser les données avant.

Ce qui me dérange, c'est que ton NAS ai "perdu" un disque, et le déclare tout de même comme sain, et que cela ne soit pas la première fois. Etait-ce bien le même disque "3" qui avait posé ce soucis ? Il aurait été intéressant de tester ce disque dans un autre système avant de tenter de le réintégrer à la grappe, en prenant les précautions nécessaires.

Pendant que tu es dans ton NAS, peux tu extraire le journal système (s'il existe) et y rechercher des traces d'anomalies ?

Vu les traces de poussières, n'hésite pas à passer un bon coup de nettoyage (y compris au niveau des berceaux des disques), et pendant que tu seras dans la maintenance, n'hésite pas à faire une sauvegarde complète sur un disque externe (prévoir 6 To et beaucoup de temps si ton NAS est plein).

Link to comment

Slt, oui la poussière est un fléau sur un NAS comme sur un ordi d'ailleurs même si des amélioration ont étaient faite en mettant des filtres partout cela ne l'empêche pas de passer, pour le disque il me semble que c'est la 2eme fois pour celui-ci est j'avais le 2 aussi mais j'avais remplacé déjà le 2 car il était marque en défaut. Le soucis c'est qu'a priori il ne trouve pas de problème et le trouve sain, donc soit il y a décrochage au moment ou il fait un enregistrement (mais normalement ça devrait passer) soit c'est autre chose. Les disques sont des Western et Seagate prévus pour NAS donc capable de "résister" à quelques problèmes mais faut pousser aussi lol.

Faire une sauvegarde demandera pas mal de temps en effets, au pire je pourrai passer par le cloud (cela évite l'achat d'un disque 6T)avec cryptage des données renforcé pour la quantité mais faudrait voire comment effectuer cela (soit en passant par l'ordi mais faut laisser les 2 allumé, soit par un logiciel dédié), si tu as une soluce je suis preneur.

Merci pour les réponses apportées

Edited by Mc82
rajout
Link to comment

Bonjour 

Pour le probleme de non accessibilité, l'OS du NAS s'était planté, on dirait.

Le 4eme disque, il était bien dans la grappe, ou alors était-il en spare ? 
C'est bizarre qu'il soit sain, mais ce sont les données SMART qui indiquent qu'il est sain.
Si il a été sorti de la grappe, celle-ci devrait etre en fail, et attendre une reconstruction.

Pour la clé USB, je pense plutot  à un dongle, qui activerait une licence logicielle.

Link to comment

Cette clé me laisse perplexe en effet, car elle est connectée via un adaptateur directement sur la carte mère.

  • Ce dongle USB était-il livré d'origine avec ce NAS ?
  • A défaut de référence sur ce dongle USB, peux-tu nous donner la référence exacte de la carte mère que l'on essai de voir à quoi correspond le connecteur sur lequel il est connectée ?

Pour ce qui est de la sauvegarde, le cloud n'est à mon avis à cette heure pas envisageable sur un volume de données aussi important : que ce soit le coût annuel (à partir de 150€ /an chez Dropbox, et 250€ /an chez KDrive), et le débit de la connexion nécessaire (grosse fibre obligatoire, sauf à vouloir saturer sa connexion durant des mois), cela ne remplacera pas le coût et la facilité d'un disque externe (6 To c'est 150€ environ) ou d'un 2nd NAS...

Link to comment
Il y a 13 heures, Longaripa a dit :

Bonjour 

Pour le probleme de non accessibilité, l'OS du NAS s'était planté, on dirait.

Le 4eme disque, il était bien dans la grappe, ou alors était-il en spare ? 
C'est bizarre qu'il soit sain, mais ce sont les données SMART qui indiquent qu'il est sain.
Si il a été sorti de la grappe, celle-ci devrait etre en fail, et attendre une reconstruction.

Pour la clé USB, je pense plutot  à un dongle, qui activerait une licence logicielle.

Bonsoir a tous, pour le disque il était en place pour un fonctionnement en raid5. Pour la clé USB je pense que c'est une sécurité ou une licence pour le logiciel (dongle avec licence je n'y avait pas pensé).

Il y a 12 heures, Toto61 a dit :

Cette clé me laisse perplexe en effet, car elle est connectée via un adaptateur directement sur la carte mère.

  • Ce dongle USB était-il livré d'origine avec ce NAS ?
  • A défaut de référence sur ce dongle USB, peux-tu nous donner la référence exacte de la carte mère que l'on essai de voir à quoi correspond le connecteur sur lequel il est connectée ?

Pour ce qui est de la sauvegarde, le cloud n'est à mon avis à cette heure pas envisageable sur un volume de données aussi important : que ce soit le coût annuel (à partir de 150€ /an chez Dropbox, et 250€ /an chez KDrive), et le débit de la connexion nécessaire (grosse fibre obligatoire, sauf à vouloir saturer sa connexion durant des mois), cela ne remplacera pas le coût et la facilité d'un disque externe (6 To c'est 150€ environ) ou d'un 2nd NAS...

Le ,dongle est d'origine avec le NAS

Pour le type de carte mere je dois attendre la fin (j'avais oublié de faire appliqué lol) de la reconstruction de la grappe pour démonter la carte et voir sa référence. Je vous mets donc en attente pour le moment le temps de la reconstruction du démontage (et inverse) et je reviens vers vous avec ce qu'il faut.

Link to comment

Bonjour, suite des événements. Donc je pense que le problème venait du disque dur n° 3 que je viens de changer, en effet j'avais beau demander la reconstruction de la grappe que celle-ci se lançait sans aller jusqu'au bout et me redonner des erreurs de disque. J'ai donc changé le disque et la reconstruction est lancé normalement (espérant que ce n'est que ce problème la et que j'arrive au terme de celle-ci (pour le moment 15%)).

Pour la carte, bien sur il fallait presque tous démonter pour voir ce que c'était (et remonter sans se tromper).

La référence :Minix H61M-USB3

Voila, bon maintenant je pense qu'il faudrait que je voie pour changer de logiciel car celui-ci n'est plus mis a jour depuis quelques années et malgré qu'il n'a pas d'accès à l'extérieur cela lui ferai un grand bien. Mon soucis c'est que je pense que je pourrais pas changer sans un formatage automatique (du au nouveau logiciel), ensuite trouver un logiciel (gratuit si possible vue ce qu'en j'en fais) qui puisse me permettre de faire ce que je veux dessus (mettre les logiciels et autres sécurité etc...).

Voila les dernières nouvelles je pense qu'après je pourrais mettre résolu et peut être réouvrir un post sur un logiciel NAS sachant qu'il faut que je sache si cette clé ne me bloquera pas dans cette démarche.

Dans tous les cas je vais quand même attendre de terminer la reconstruction ainsi que faire le test avant de conclure (on ne sait jamais).

Link to comment

Ce Dongle USB est branché sur le FUSB1, connecteur traditionnel permettant l'extension des ports USB, à travers une carte intermédiaire. Sur cette carte, y sont connectés quelques câbles. Vu qu'il y a du violet, ce câble viendrait-il de l'alimentation électrique ? Si oui, y'a t'il :

  • un signal WiFi
  • un signal Bluetooth
  • une télécommande

Nativement, la carte mère ne contient aucune de ses fonctions suivant la fiche technique, et on ne serait pas à l'abris d'un bricolage maison de feu Ve-Hotech pour ajouter ce genre de fonction à un coût réduit.

Link to comment

Slt, pour ce genre dongle malheureusement je ne peux répondre, cependant je suis sur qu'il n'y a pas de Wifi et de Bluetooth dessus ensuite pour la télécommande il n'y en avait pas avec ni en option.

Je viens de regarder vue que le NAS et ouvert je mets quelque photos que je viens de prendre et les fils violet correspondraient plus (à priori) à l'alimentation du voyant danger et au reset du NAS(bouton au dessus de celui de coupure du son).

IMG_20210924_155209.png

IMG_20210924_155410.png

IMG_20210924_155423.png

Link to comment

Si c'est le bouton Reset du NAS qui est connecté sur cette interface JUSB1, cela veut dire qu'il s'agit très certainement d'un simple clé USB qui contient une image de l'OS du NAS, permettant de la réinjecter sur les disques de ce dernier pour réinitialiser le mot de passe principal, et les ports d'accès à la configuration (sans toucher aux données), ou de le réinitialiser intégralement (avec destruction des données).

Link to comment

Donc a priori, je pourrai mettre un autre OS dessus mais il faudra que je fasse une sauvegarde complet avant de faire quoi que ce soit.

Je viens de voir sur le descriptif de la CM qu'il y a un Bios UEFI surprenant (acheté en 2014) à mon avis ce devait être le balbutiement de ce bios lol

En revanche je suppose que pour voir le système complet il faut que je branche un moniteur sur le NAS ainsi qu'un clavier/souris.

Pour le moment tous ce passe bien, je pense que le disque posait problème (sans comprendre pourquoi je n'avais pas accès par réseau tout de même), celui qui est mis en place pour le moment est à 32% de remplissage (donc faut croiser les doigts lol), si celui-ci va jusqu'au bout je vous avertirez et cela me permettra de mettre résolu pour ce post.

Il faudra en revanche que je trouve un post ou en créer un pour modifier mon NAS afin de changer complètement le logiciel, mais ça c'est une autre histoire :rolleyes:.

Link to comment

Ce n'est pas un NAS en tant que tel, mais un "miniPC" avec une version Ubuntu, dans un boitier de NAS (on pourrait d'ailleurs saluer ce point de détail tellement c'est rare chez les constructeurs/assembleurs de NAS qui préfèrent souvent verrouiller leurs "OS Maison"...). Reste à voir si Ve-Hotech avait développé un BIOS verrouillé / limité pour ce type de carte mère. Il faudra y brancher un clavier / souris USB et un écran pour voir si l'accès au BIOS est possible. Si c'est le cas, tu devrais pouvoir bidouiller quelque chose en cherchant du coté de FreeNAS.

Tu auras peut-être plus de support du coté de https://www.forum-nas.fr/

  • J'aime 1
Link to comment

C'est un peu la question que je me suis posé également. Mais ce serait sacrément osé de la part de Ve-Hotech, car la fiabilité d'une clé USB connectée en permanence dans une tour qui de plus n'est pas ventilé, on repassera ! J'ose juste espérer qu'elle contient une sauvegarde de l'OS, prête à être réinjectée sur les disques en cas de pépin.

Link to comment

Re

il y a 57 minutes, Toto61 a dit :

Ce n'est pas un NAS en tant que tel, mais un "miniPC" avec une version Ubuntu, dans un boitier de NAS (on pourrait d'ailleurs saluer ce point de détail tellement c'est rare chez les constructeurs/assembleurs de NAS qui préfèrent souvent verrouiller leurs "OS Maison"...). Reste à voir si Ve-Hotech avait développé un BIOS verrouillé / limité pour ce type de carte mère. Il faudra y brancher un clavier / souris USB et un écran pour voir si l'accès au BIOS est possible. Si c'est le cas, tu devrais pouvoir bidouiller quelque chose en cherchant du coté de FreeNAS.

J'espère que non, si le BIOS est verrouillé je verrai pour le flasher avec une MAJ, s'il y en a encore une :huh:

il y a 10 minutes, Longaripa a dit :

Re 

La question que je me pose, c'est : ou est stocké l'OS ? 

Sur certains NAS (la plupart), il est dans les disques durs, dans une partition reservée au début.

Là, ne pourrait-il pas etre dans le dongle USB, qui agirait comme live-OS , avec persistance? 

Justement, j'attend la fin de la synchronisation pour mettre un écran/clavier/souris afin de voir les options qui s'offre à moi. Dans tout les cas il faudra que je fasse une sauvegarde complète des données avant.

Link to comment
il y a 2 minutes, Toto61 a dit :

C'est un peu la question que je me suis posé également. Mais ce serait sacrément osé de la part de Ve-Hotech, car la fiabilité d'une clé USB connectée en permanence dans une tour qui de plus n'est pas ventilé, on repassera ! J'ose juste espérer qu'elle contient une sauvegarde de l'OS, prête à être réinjectée sur les disques en cas de pépin.

Heuuuu, c'est ventilé heinnn mais a l'arrière côté disque pas côté carte ils ont estimé que le ventilo du processeur devait suffire à le faire :tongue:

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...