meridian-shaft Jump to content
Forums

Ubuntu 20.10 - Mise à niveau et désagréables surprises


Solved

Recommended Posts

Bonjour,

J'ai aujourd'hui même mis à niveau mon ordinateur vers Ubuntu 20.10, afin de voir ce qu'apporte cette nouvelle version.

L'installation s'est bien passée. Après redémarrage du PC, je vais dans le menu des applications pour voir si le design a changé, et alors là, grosse (mauvaise) surprise !

Mes lanceurs du menu ne prenaient que deux ou trois pages (les points blancs sur le côté), et là, je me retrouve avec 8 pages !!!

Il y a juste 118 lanceurs de plus... Ils possèdent tous la même icône, un rectangle bleu aux coins arrondis avec la mention "LSP" écrite en blanc.

J'ai recherché d'où pouvait venir ce problème, et j'ai trouvé une page qui en parlait (https://askubuntu.com/questions/1286877/applications-menu-filled-with-lots-of-lsp-apps-after-upgrading-to-ubuntu-20-10) et l'utilisateur en question a exactement le même problème que moi.

Note importante, l'apt lsp-plugins n'est pas présent sur mon ordinateur, (en faisant sudo apt remove lsp-plugins le terminal me dit que ce paquet n'et pas installé et qu'il ne peut pas être supprimé). Je ne savais même pas ce que c'était (en cliquant sur les lanceurs, divers logiciels d'analyse audio s'ouvrent) !! Et quand un des processus est actif (nom du processus : lsp-plugins-xxxx avec xxxx comme nom du plugin), je regarde dans le moniteur système, clique droit sur le processus en question et dans le menu contextuel clique sur "Fichiers ouverts", je tombe sur ça :

image.png.3f803b238c999af7c00f4d423ce4e64f.png

Pour revenir au topic que j'ai trouvé sur askubuntu, la réponse disait (je traduis approximativement) qu'il faut utiliser un éditeur de menus (j'ai installé MenuLibre), à l'intérieur sélectionner lsp-plugins et activer l'option qui permet de cacher le lanceur. A première vue, c'est simple, rapide et efficace, non ? Et bien j'ai fait comme indiqué ; rien. J'ai essayé de rentrer sudo menulibre dans un Terminal, MenuLibre dit qu'il ne peut pas être exécuté en tant qu'administrateur... Je ré-applique le fait de cacher les plugins lsp et je redémarre, rien.

Je suis assez embêté par cela, une idée d'où cela viendrait ? Comment le résoudre ?

Cordialement,

TechFox

Link to post
il y a une heure, TechFox a dit :

Bonjour,

J'ai aujourd'hui même mis à niveau mon ordinateur vers Ubuntu 20.10, afin de voir ce qu'apporte cette nouvelle version.

L'installation s'est bien passée. Après redémarrage du PC, je vais dans le menu des applications pour voir si le design a changé, et alors là, grosse (mauvaise) surprise !

Mes lanceurs du menu ne prenaient que deux ou trois pages (les points blancs sur le côté), et là, je me retrouve avec 8 pages !!!

Il y a juste 118 lanceurs de plus... Ils possèdent tous la même icône, un rectangle bleu aux coins arrondis avec la mention "LSP" écrite en blanc.

J'ai recherché d'où pouvait venir ce problème, et j'ai trouvé une page qui en parlait (https://askubuntu.com/questions/1286877/applications-menu-filled-with-lots-of-lsp-apps-after-upgrading-to-ubuntu-20-10) et l'utilisateur en question a exactement le même problème que moi.

Note importante, l'apt lsp-plugins n'est pas présent sur mon ordinateur, (en faisant sudo apt remove lsp-plugins le terminal me dit que ce paquet n'et pas installé et qu'il ne peut pas être supprimé). Je ne savais même pas ce que c'était (en cliquant sur les lanceurs, divers logiciels d'analyse audio s'ouvrent) !! Et quand un des processus est actif (nom du processus : lsp-plugins-xxxx avec xxxx comme nom du plugin), je regarde dans le moniteur système, clique droit sur le processus en question et dans le menu contextuel clique sur "Fichiers ouverts", je tombe sur ça :

image.png.3f803b238c999af7c00f4d423ce4e64f.png

Pour revenir au topic que j'ai trouvé sur askubuntu, la réponse disait (je traduis approximativement) qu'il faut utiliser un éditeur de menus (j'ai installé MenuLibre), à l'intérieur sélectionner lsp-plugins et activer l'option qui permet de cacher le lanceur. A première vue, c'est simple, rapide et efficace, non ? Et bien j'ai fait comme indiqué ; rien. J'ai essayé de rentrer sudo menulibre dans un Terminal, MenuLibre dit qu'il ne peut pas être exécuté en tant qu'administrateur... Je ré-applique le fait de cacher les plugins lsp et je redémarre, rien.

Je suis assez embêté par cela, une idée d'où cela viendrait ? Comment le résoudre ?

Cordialement,

TechFox

Bonjour,

il n'a jamais été bon de passer d'une version LTS en faisant un upgrade à une nouvelle version, il y a même des fois ou passer d'une version LTS à une autre LTS faisait planter la machine ... eh oui ça arrive aussi avec le pingouin.

Ce qui c'est certainement passer, c'est que tu as maintenant les dépôts de ta version LTS qui sont en conflits avec les nouveaux dépôts.

Que rapporte la commande en administrateur:

/etc/apt/sources.list

 

Link to post

Ahhh d'accord j'avais compris qu'il fallait utiliser sudo, pas root.

Voilà le retour du terminal :

# deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu focal partner
# deb-src http://archive.canonical.com/ubuntu focal partner

deb http://security.ubuntu.com/ubuntu groovy-security main restricted
# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu groovy-security universe
# deb-src http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu groovy-security multiverse
# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

 

Link to post
il y a 55 minutes, TechFox a dit :

Ahhh d'accord j'avais compris qu'il fallait utiliser sudo, pas root.

Voilà le retour du terminal :

# deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu focal partner
# deb-src http://archive.canonical.com/ubuntu focal partner

deb http://security.ubuntu.com/ubuntu groovy-security main restricted
# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu groovy-security universe
# deb-src http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu groovy-security multiverse
# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

 

ça à l'air d'être en ordre au niveau des différents paquets de ta nouvelle distribution.

Après c'est comme je t'ai dit, il n'est jamais recommandé de faire un upgrade d'une version LTS à une version "standard", déjà d'une LTS à une autre LTS n'est pas gagné d'avance.

A ce propos, comment as-tu fait cet upgrade, via le terminal ou via logiciels et mise à jour ?

Link to post
il y a une heure, Tulburite a dit :

A ce propos, comment as-tu fait cet upgrade, via le terminal ou via logiciels et mise à jour ?

Via le gestionnaire de mise à jour.

il y a une heure, Tulburite a dit :

il n'est jamais recommandé de faire un upgrade d'une version LTS à une version "standard", déjà d'une LTS à une autre LTS n'est pas gagné d'avance.

Alors à chaque fois on doit réinstaller avec l'iso ??? Pourquoi est-ce risqué ?

Link to post
Il y a 5 heures, TechFox a dit :

Via le gestionnaire de mise à jour.

Alors à chaque fois on doit réinstaller avec l'iso ??? Pourquoi est-ce risqué ?

Une version standard est soutenue 9 mois et tu ne vas pas travailler avec une version qui ne sera plus à jour moins d’une année après, perso je ne vois pas de raison.

Une version LTS est soutenue 5 ans avec des logiciels « figés » sur la durée (un peu moins maintenant). Le fait de faire un upgrade entre une version standard avec des nouveaux logiciels et une version LTS avec des logiciels « figés » et un noyau optimisé pour une version LTS (malgré les mises à jour réguliers) fout certainement le merdier ... Après je peux pas te donner la raison exacte ...

Perso, j’installe toujours une version LTS sur ma bécane et je fais une réinstallation safe à chaque nouvelle version après un test de plusieurs mois sur une autre machine identique à ma machine de production. Par contre je teste en VM  les versions standards mais qui entre nous ne m’apporte rien. Je pense que tu (nous) ne pouvons pas nous plaindre de devoir réinstaller un système gratuit ... 

Link to post
Le 29/04/2021 à 16:27, TechFox a dit :

Bonjour @Tulburite,

Je vais donc sous peu installer Xubuntu.

Mais j'ai quelques doutes subsistant au sujet de la marche à suivre : dois-je désinstaller complètement Ubuntu et le GRUB comme indiqué dans l'article du Crabe (Désinstaller Ubuntu d'un PC en dual-boot Windows+Linux) ou alors autre chose ?

Bonjour @TechFox

Tu procèdes à une installation standard en supprimant Ubuntu une fois que l'installateur te demande ce que tu veux faire simplement

Link to post
Posted (edited)
Il y a 15 heures, Tulburite a dit :

Bonjour @TechFox

Tu procèdes à une installation standard en supprimant Ubuntu une fois que l'installateur te demande ce que tu veux faire simplement

Bonjour !

Donc si j'ai bien compris (désolé j'insiste mais je veux être sûr de la marche à suivre) je sauvegarde mes fichiers, je mets l'iso de Xubuntu sur une clé USB vierge, je boote dessus depuis le BIOS. Dans l'installateur, j'installe Xubuntu sur la partition de 80 Go déjà allouée à Ubuntu (et donc par logique l'installateur va la formater) et j'y installe Xubuntu. C'est ça ?

Edited by TechFox
Link to post
Il y a 6 heures, TechFox a dit :

Bonjour !

Donc si j'ai bien compris (désolé j'insiste mais je veux être sûr de la marche à suivre) je sauvegarde mes fichiers, je mets l'iso de Xubuntu sur une clé USB vierge, je boote dessus depuis le BIOS. Dans l'installateur, j'installe Xubuntu sur la partition de 80 Go déjà allouée à Ubuntu (et donc par logique l'installateur va la formater) et j'y installe Xubuntu. C'est ça ?

Bonjour,

Oui

Link to post

Bonjour,

Maintenant que j'ai eu réponse à toutes mes questions, je tiens à te remercier @Tulburite pour ta grande aide et tes précieux conseils.

Pour les prochaines personnes qui regarderont le topic, retenez une chose : sur Ubuntu, évitez de faire la mise à jour d'une version LTS (Long Term Support - en bon français support à long terme) à une autre version, Ubuntu n'est pas Windows ! Les version LTS sont supportées pendant 5 ans, avec des mises à jour de sécurité tout au long du support, donc inutile de vous jeter sur une nouvelle mise à jour dès qu'elle sort.

Et pour passer d'une version LTS à une autre, le meilleur est de ré-installer complètement le système afin d'être sûr d'avoir un support d'installation propre ;)

  • J'aime 2
Link to post
Il y a 13 heures, TechFox a dit :

Bonjour,

Maintenant que j'ai eu réponse à toutes mes questions, je tiens à te remercier @Tulburite pour ta grande aide et tes précieux conseils.

Pour les prochaines personnes qui regarderont le topic, retenez une chose : sur Ubuntu, évitez de faire la mise à jour d'une version LTS (Long Term Support - en bon français support à long terme) à une autre version, Ubuntu n'est pas Windows ! Les version LTS sont supportées pendant 5 ans, avec des mises à jour de sécurité tout au long du support, donc inutile de vous jeter sur une nouvelle mise à jour dès qu'elle sort.

Et pour passer d'une version LTS à une autre, le meilleur est de ré-installer complètement le système afin d'être sûr d'avoir un support d'installation propre ;)

Bonjour,

De plus je viens de lire comme quoi l’installateur d’Ubuntu 20.10 posait problème suivant le type d’installation que l’on désirait faire et surtout en mode légacy 

Link to post
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...