meridian-shaft Jump to content
Forums

Connexion VPN au lancement du système.


Solved

Recommended Posts

Bonjour à tous !

Je viens de souscrire un abonnement VPN chez SurfShark. Cela fonctionne parfaitement sauf que... je suis obligé de le connecter manuellement au démarrage.

En effet, n'ayant pas encore d'application Linux, le fournisseur met à disposition un fichier de configuration à installer très simplement via le Network-Manager de Linux (cf : capture écran ci-dessous), mais impossible de paramétrer la connexion automatique. J'ai parcouru je ne sais combien de forums mais rien à faire, rien ne fonctionne.

Alors si les aficionados Linux comme moi ont une solution, je suis évidemment preneur.

Je rappelle que je suis sous Mint 20.1 avec environnement de bureau Cinnamon.

Merci !

Capture d’écran du 2021-04-03 19-55-52.png

Link to post
Il y a 2 heures, zelandonii a dit :

Bonjour à tous !

Je viens de souscrire un abonnement VPN chez SurfShark. Cela fonctionne parfaitement sauf que... je suis obligé de le connecter manuellement au démarrage.

En effet, n'ayant pas encore d'application Linux, le fournisseur met à disposition un fichier de configuration à installer très simplement via le Network-Manager de Linux (cf : capture écran ci-dessous), mais impossible de paramétrer la connexion automatique. J'ai parcouru je ne sais combien de forums mais rien à faire, rien ne fonctionne.

Alors si les aficionados Linux comme moi ont une solution, je suis évidemment preneur.

Je rappelle que je suis sous Mint 20.1 avec environnement de bureau Cinnamon.

Merci !

Capture d’écran du 2021-04-03 19-55-52.png

Bonjour @zelandonii

Je pense pas que je puisse t'apprendre quelques choses avec le pingouin, mais as-tu essayé de passer par les applications au démarrage

1316403636_Dmarrage.png.4ef7410ec05427dc8e066b7b3bdf23fe.png

Bon, je suis pas avec ma machine principale ou j'ai Mint en VM mais il doit y avoir une correspondance entre Ubuntu et Mint

Link to post
il y a 1 minute, Tulburite a dit :

Bonjour @zelandonii

Je pense pas que je puisse t'apprendre quelques choses avec le pingouin,...

Ne crois pas ça.

Oui, je ne trouvais pas l'application alors j'ai essayé avec un sudo autostart, mais rien non plus.

Link to post
il y a 15 minutes, zelandonii a dit :

Oui, je ne trouvais pas l'application alors j'ai essayé avec un sudo autostart, mais rien non plus.

Il est comment ton fichier de configuration, autrement il faut fabriquer un script et l'installer dans les programmes au démarrage de Mint

1965123342_Capturedcrandu2021-04-0322-33-25.thumb.png.5a48c230802856b1e2669cbe09aa2f1b.png

Link to post

Je te le transmettrai demain.

Oui je pensais aussi que c'était la seule solution ou rajouter des commandes dans le fichier de base open vpn.

Merci, à demain.

Bonne nuit.

Link to post
il y a 5 minutes, zelandonii a dit :

Je te le transmettrai demain.

Oui je pensais aussi que c'était la seule solution ou rajouter des commandes dans le fichier de base open vpn.

Merci, à demain.

Bonne nuit.

Peut-être plus simple ... regarde cet article, bon c'est sous Ubuntu mais ça doit être pareil.

Je vais pas beaucoup être sur le forum demain, fête de famille oblige :-)

Bonne nuit également et au plaisir de te relire.

Edited by Tulburite
Link to post

Bonsoir @Tulburite,

Je n'ai pas pris le temps de me pencher plus que ça sur ton lien mais je l'avais déjà "croisé". J'ai trouvé deux logiciels, Lifeguard VPN et VPN check, qui permettent de contrôler le VPN mais je n'arrive à faire fonctionner aucun des deux, sûrement parce que le fichier de configuration est sous Open VPN.

Je continue à chercher mais ce que je trouve le plus étonnant, c'est qu'ils n'auraient pas pensé à créer un démarrage automatique de Network Manager.:blink:

Link to post
Il y a 21 heures, zelandonii a dit :

Bonsoir @Tulburite,

Je n'ai pas pris le temps de me pencher plus que ça sur ton lien mais je l'avais déjà "croisé". J'ai trouvé deux logiciels, Lifeguard VPN et VPN check, qui permettent de contrôler le VPN mais je n'arrive à faire fonctionner aucun des deux, sûrement parce que le fichier de configuration est sous Open VPN.

Je continue à chercher mais ce que je trouve le plus étonnant, c'est qu'ils n'auraient pas pensé à créer un démarrage automatique de Network Manager.:blink:

Bonjour @zelandonii

Je viens de faire quelques recherches et effectivement rien n’est facile avec les VPN sur GNU/Linux,

Cependant il existe un .déb pour l’installation de Lifeguard VPN que tu trouves ici, as-tu essayé cette version ?

Pour te rassurer, ou pas, j’ai jamais réussi à installer un VPN en L2TP IPsec avec une distribution GNU/Linux malgré le concours d’une grande école de formation en informatique près de chez moi, afin que je puisse me connecter sur mon NAS qui se trouve chez ma fille (bon c’est différent que ta demande ...)

Link to post

Je crois que c'est celui-ci mais je vais quand même réessayer.

N'empêche qu'installer un VPN, c'est installer un VPN. Et le problème de mon fournisseur, c'est qu'ils n'ont pas encore d'application Linux. J'espère que cela ne va pas trop tarder.

Link to post
il y a une heure, zelandonii a dit :

Je crois que c'est celui-ci mais je vais quand même réessayer.

N'empêche qu'installer un VPN, c'est installer un VPN. Et le problème de mon fournisseur, c'est qu'ils n'ont pas encore d'application Linux. J'espère que cela ne va pas trop tarder.

Oui je suis d'accord avec toi mais ...

Autrement je viens de tomber sur cette façon de faire

Link to post

C'est à peu de choses près  la méthode que j'ai utilisé, sauf qu'il n'y a toujours pas de moyen pour que le Network Manager lance le VPN automatiquement au démarrage du système.

Link to post
il y a 3 minutes, zelandonii a dit :

C'est à peu de choses près  la méthode que j'ai utilisé, sauf qu'il n'y a toujours pas de moyen pour que le Network Manager lance le VPN automatiquement au démarrage du système.

As-tu suivi cette méthode ... peut-être que

Link to post
Posted (edited)

La première  sur laquelle je suis tombé...:biggrin: Et la seule que je n'ai pas essayée car je partais dans plusieurs directions à  la fois....

Merci, c'est super.

Edited by zelandonii
Link to post
il y a 12 minutes, zelandonii a dit :

La première  sur laquelle je suis tombé...:biggrin: Et la seule que je n'ai pas essayée car je partais dans plusieurs directions à  la fois....

Merci, c'est super.

Et ça fonctionne ?

Link to post
il y a 7 minutes, zelandonii a dit :

Pas le courage d'essayer ce soir, peut-être demain sinon ce sera ce week-end. Le merci c'est pour tes recherches.

Je te comprends et c'est normal de se donner un coup de main :rolleyes:

Bonne soirée

  • J'adore 1
Link to post

Bonsoir @Tulburite,

Problème réglé. Mon fournisseur n'ayant pas encore d'application Linux et le Network Manager ne démarrant pas automatiquement au lancement du système, j'ai résilié et suis revenu chez le précédent, qui est très bien soit dit-en passant.

Merci encore de ton aide.

Link to post
il y a une heure, zelandonii a dit :

Bonsoir @Tulburite,

Problème réglé. Mon fournisseur n'ayant pas encore d'application Linux et le Network Manager ne démarrant pas automatiquement au lancement du système, j'ai résilié et suis revenu chez le précédent, qui est très bien soit dit-en passant.

Merci encore de ton aide.

Bonsoir @zelandonii

Merci pour le retour, il y a encore du chemin à parcourir malheureusement avec les fournisseurs et les fabricants etc ...

  • J'adore 1
Link to post
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.