Jump to content
Forums

Code d'erreur 0x80070002


Solved

Recommended Posts

Bonjour,

Voila quelques jours que je m'acharne a faire fonctionner windows update pour installer les mises a jour téléchargeables. Cependant le code d'erreur 0x80070002 revient en long, en large et en travers.

Apres quelques péripéties sur internet j'ai essayé toutes les solutions proposées sur ce site https://www.ionos.fr/digitalguide/serveur/configuration/erreur-0x80070002/  aucune ne m'a permis de resoudre mon problème.

Voulant l'installer manuellement j'ai cherché sur le catalogue microsoft via le code (KB...), je n'ai pas trouvé la mise a jour exacte correspondant a celle de mon windows update.

Je me retrouve donc dans l'impasse et me tourne vers vous.

Ci-joint vous trouverez 2 screens pouvant être eventuellement utile.

 

image.png.af3c7d6a89f5fb3a42aec6c99409f5ab.png

image.png.69c5372b96cddc9413282e3e3cfd9967.png

Link to post
  • Replies 79
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Bonjour, Pour le cas où cela puisse servir de piste, j'ai rencontré le même problème de mise à jour, avec le même code erreur à peu près la même période que toi. J'ai essayé la plupart des m

Bonjour,  Merci a tous pour l’aide apportée !!! Le pc se comporte bien passé 24h c’est super.    Dorénavant lecrabeinfo restera dans mes marques pages 

Salut @calisto06, Voici le screen de crystal disk : C'est d'ailleurs a ma grande surprise que l'etat affiché soit bon ( haha). Concernant les commandes lié a DISM, le scanhealth ainsi

Posted Images

Bonjour @Jamb0- 

On va dans un premier temps vérifier que le disque dur du PC est en bon état à l'aide de l'outil Crystal disk info portable http://www.gratilog.net/xoops/modules/mydownloads/singlefile.php?cid=226&lid=1911

Postez un screen du résultat 

Ensuite si le disque est en bon état faite une réparation des fichiers systèmes à l'aide de DISM https://lecrabeinfo.net/reparer-image-de-windows-10-dism.html

relancez update et voyez ce que ça dit 

Link to post

Salut @calisto06,

Voici le screen de crystal disk : image.png.858b58993ff9a9f0339598c37245ed90.png

C'est d'ailleurs a ma grande surprise que l'etat affiché soit bon ( haha).

Concernant les commandes lié a DISM, le scanhealth ainsi que le checkhealth montre que l'image est réparable.

image.png.110edc911c1a68b15c83d34c35569e13.png

image.png.4c066d416c1dadaddb0758c7c91ae731.png

En effectuant la commande restorehealth je me trouve confronté a l'erreur 0x800f081f, ce qui semble logique etant donné que le but est de réparé windows update.

Je télécharge acutellement l'iso de windows afin de passer par une source alternative a windows update.

Je reviens vers vous une fois les telechargement et manipulation faites !

 

  • J'aime 1
Link to post

Il y a une méthode radicale pour réparer le système c'est la réparation sans perte de données à l'aide de l'iso de la même version 

https://www.chantal11.com/2015/11/reparer-installer-windows-10-mise-a-niveau-sans-perte-de-donnees-ni-applications-et-parametres-depuis-le-fichier-iso/

Ca vient quasi à bout de toutes les erreurs système , c'est un peu long mais efficace.

La dernière option étant la réinstallation en clean install mais là on perd tout ce qui est sur le lecteur .

Link to post

J'étais justement en train de rédiger un message.

Malgré la réparation via la source externe qu'est l'iso l'erreur reste présente. En scrollant un peu plus bas sur la page je ne comprends plus grand chose. 

Je vais voir le dernier lien fournit dans votre message précédent, au premier regard ça me semble simple et efficace et en terme de temps ça fait déjà quelques jours que je suis sur le problème alors un ou deux de plus ce n'est pas grand chose.

  • J'aime 1
Link to post

Me revoilà avec un nouveau challenge, sinon on s'ennuierait !

Un nouveau code d'erreur est apparue lors de la réinstallation de windows 10 : 0x8007001F - 0x20006 (cf screen)

image.png.1052122e3fcc6cd7740280c802dc4d4c.png

Je regarderais un peu demain ce qu'il en est sur lecrabeinfo.net mais pour être franc je suis dans l'optique de prendre un disque dur externe pour y mettre mes données et faire une raz sur l'ordinateur

A moins évidemment qu'il existe des solutions alternative pour lesquelles je suis tout ouïe.

Link to post

Fais ceci

D'abord vérifie que tu as assez de place sur le disque dur (30 g iront) 

Supprime le dossier  $Windows.~BT https://www.commentcamarche.net/faq/49083-windows-bt-qu-est-ce-que-c-est  si présent 

En invite de commande administrateur copie colle les commandes suivantes , cliquer sur enter après chaque commande 

net stop wuauserv 

net stop cryptsvc

md% systemroot% system32 catroot2.old

xcopy% systemroot% system32 catroot2% systemroot% system32 catroot2.old / s 

supprime tout le contenu du dossier catroot2

Toujours en invite de commande administrateur 

net start cryptsvc 

net start wuauserv

Ferme l'invite de commande 

Déconnecte un maximum de périphériques (usb non utiles hdmi sauf écran , carte sd ..) , si tu as un antivirus tiers désinstalle le avec son outil (voir site de l'éditeur )

Désinstalle tous les logiciels non utilisés (daemon tool par ex....) 

Vérifie les mises à jour des pilotes https://support.microsoft.com/fr-fr/windows/mettre-à-jour-les-pilotes-dans-windows-10-ec62f46c-ff14-c91d-eead-d7126dc1f7b6

Relance la réparation DISM  

Donne le résultat 

Link to post

Bonjour calisto,

Désolé de ne pas avoir repondu plus tôt c'est un peu le rush en ce moment.

Je me penche dès ce week-end sur la solution que tu m'as proposé ci dessus.

Je te tiens au courant ! d'ici la bonne semaine !

Link to post

Bonjour @calisto06,

Je suis actuellement en train d'executer les commandes sur l'invite et je rencontre ceci suite a la commande :

md% systemroot% system32 catroot2.old

image.png.c2fe6d730cc1349c0c9a632591a4b0dc.png

Il en va de même pour la commande :

xcopy% systemroot% system32 catroot2% systemroot% system32 catroot2.old / s

Dois-je continuer a procéder avec la suite des commandes en sachant que je ne peux pas supprimer le dossier catroot2 ?

 

Link to post
Posted (edited)

J'ai lancer le fichier en administrateur puis reboot le pc mais le problème persiste pour les deux commandes

image.png.187750dc8474259f93b9b2d2691ffb61.png

J'ai en attendant désinstaller tout les logiciels non utilisé depuis plus de 3 mois afin de liberer le plus d'espace possible. Mon antivirus tiers est désinstallé, j'ai vérifié tout les pilotes un par un ils sont tous a jour. Le seul port utilisé sur mon ordinateur est celui du câble d'alimentation (pas de souris etc)

Edited by Jamb0-
Link to post
il y a 41 minutes, Jamb0- a dit :

J'ai en attendant désinstaller tout les logiciels non utilisé depuis plus de 3 mois afin de liberer le plus d'espace possible. Mon antivirus tiers est désinstallé,

Tu as combien d'espace libre ? Pour info le nettoyage des fichiers système supprime le dossier Windows .old très volumineux  https://lecrabeinfo.net/supprimer-dossier-windows-old-sur-windows-10.html

Comment as tu désinstallé l'antivirus ? Il faut utiliser la procédure de l'éditeur 

Télécharge Winupdatefix https://toolslib.net/downloads/viewdownload/21-winupdatefix/ (qui fonctionne aussi avec w10)

Clique sur créer un rapport de diagnostic (peut être utilisé si besoin) : il sera ici C:\WinUpdateFix.txt 

Coche

Effacer le catalogue des mises à jour

Vider le dossier SoftwareDistribution

Supprimer les fichiers temporaires

Exécuter puis redémarrer 

Si pas mieux coche toutes les cases et recommence l'opération 

Link to post

Pour l'antivirus je suis allé sur le site du fournisseur pour avoir les étapes a suivre pour une désinstalation propre.

Il me reste actuellement 131go de mémoire. Le dossier odl n'etant deja plus existant depuis pas mal de temps (la derniere maj remonte a quelques mois maintenant)

J'ai téléchargé Winupdatefix en cochant d'abord les cases que tu m'as indiquer puis reboot etc => le resultat ne change pas

image.png.63f06779d17bc219323ecba32da870da.png

Idem en cochant toutes les cases puis en rebootant.

Veux-tu que j'insère en pièce jointe le .txt relatif a Winupdatefix ?

 

Link to post

Salut,

Si je peux me permettre une petite incartade rapide @calisto06, les 2 commandes indiquées par @Jamb0- sont erronées :

Citation

 

md% systemroot% system32 catroot2.old -> md %systemroot%\system32\catroot2.old

xcopy% systemroot% system32 catroot2% systemroot% system32 catroot2.old / s -> xcopy %systemroot%\system32\catroot2  %systemroot%\system32\catroot2.old \s

 

Edited by calisto06
Link to post

recommence il a fallu rectifier les commandes .

Par ailleurs ça n'explique pas que l'outil WinUpdateFix  ne fonctionne pas chez toi alors qu'il marche impec chez moi .

Link to post
Posted (edited)

La premiere commande fonctionner, cependant la deuxieme commande

xcopy %systemroot%\system32\catroot2  %systemroot%\system32\catroot2.old \s semble comporter une erreur

image.png.fdf1b825f717f03f29209d9a9797df2d.png

Je pensais que Winupdatefix avait bien fonctionné pour ma part :s

Edited by Jamb0-
Link to post

Juste apres redémarrage de mon pc j'ai suivi ceci, la trame que tu m'avais donné en utilisant les commandes qu'a rectifié Toto61

image.png.65d15d76e54da9fff625e43a920491cf.png

Mais a la commande xcopy %systemroot%\system32\catroot2  %systemroot%\system32\catroot2.old \s   j''obtiens le message du screen ci dessus : Nombre de paramètres non valide

Je ne suis pour l'instant pas aller supprimer le dossier catroot2.old dans le repertoir de mon disque C:

Link to post

Oui, normal, la nouille que je suis à oublié d'indiquer que c'est /s à la fin et non \s

xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.old /s

 

Edited by Toto61
Link to post
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...