meridian-shaft Jump to content
Forums

Après une mise à jour puis un redémarrage, ma souris ne fonctionne plus


Solved

Recommended Posts

Il y a 2 heures, labricole59 a dit :

Je pense que mon problème de souris n'est pas lié à la distribution car il s'est produit avec ubuntu et plusieurs variantes de Mint.

C'est mon PC qui doit être en cause, c'est une vrai teigne, j'ai installé linux sur d'autres PC même encore plus anciens

et je n'ai rencontré aucun problème sauf de la lenteur.

Et dans le démarrage automatique d'application tu as ta souris qui est cochée

Link to post
  • Replies 185
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Déjà données dans l'un des messages de la première page @rodriguem7973.

Ou Cinnamon...

Je crois que depuis que je suis membre de ce forum, cela doit être le dépannage où j'ai répondu en premier, le plus long auquel j'ai été confronté. Et ce n'est pas fini.

Posted Images

Il y a 16 heures, Tulburite a dit :

Et dans le démarrage automatique d'application tu as ta souris qui est cochée

Dans le démarrage automatique, je vois une rubrique intitulée :  Gnome setting daemon's mouse plugin.  La case de cette rubrique n'est pas cochée.  Je sais que mouse veut dire souris en anglais. Est ce que je dois cocher cette case ?

Link to post
Il y a 2 heures, zelandonii a dit :

Si je peux me permettre.

Essaie et vois si cela change quelque chose. Redémarre quand même entre les deux.

Hélas !  ça n'a rien changé. J'ai même essayé une troisième souris en vain.

Link to post
Il y a 18 heures, labricole59 a dit :

Hélas !  ça n'a rien changé. J'ai même essayé une troisième souris en vain.

C'est bizarre cette histoire,

Je viens d'installer Mint 20.1 avec le bureau XFCE sur un vieux Dell Inspiron 1720 et sur une machine virtuelle sans problème,, ça tourne bien c'est relativement réactif même sur mon vieux Dell ... As-tu essayé d'installer la dernière version mais avec un autre bureau par hasard

Link to post
il y a 31 minutes, Tulburite a dit :

C'est bizarre cette histoire,

Je viens d'installer Mint 20.1 avec le bureau XFCE sur un vieux Dell Inspiron 1720 et sur une machine virtuelle sans problème,, ça tourne bien c'est relativement réactif même sur mon vieux Dell ... As-tu essayé d'installer la dernière version mais avec un autre bureau par hasard

Re

J'insiste sur le fait que tout se passe bien et que ce n'est qu'une fois le PC redémarré que la souris ne fonctionne plus. C'est gentil de me proposer d'installer d'autres versions, mais mon PC est tellement récalcitrant à booter,

je dois effectuer trop de manips ( nomodeset nolapic ) ensuite il faut tout réinstaller, configurer le navigateur, etc...ça me prend trop de temps ( je sais je suis à la retraite lol ) - Donc pour l'instant je fonctionne avec le pavé tactile en l'attente d'une solution pour la souris. Je suis convaincu que la cause du problème vient de mon PC -

Link to post

La mise à jour doit activer elle-même une mise à jour des ports USB qui fait qu'ils ne fonctionnent plus avec ta souris.

As-tu testé d'autres périphériques, par exemple un autre clavier ?

Link to post
Il y a 1 heure, labricole59 a dit :

Re

J'insiste sur le fait que tout se passe bien et que ce n'est qu'une fois le PC redémarré que la souris ne fonctionne plus. C'est gentil de me proposer d'installer d'autres versions, mais mon PC est tellement récalcitrant à booter,

je dois effectuer trop de manips ( nomodeset nolapic ) ensuite il faut tout réinstaller, configurer le navigateur, etc...ça me prend trop de temps ( je sais je suis à la retraite lol ) - Donc pour l'instant je fonctionne avec le pavé tactile en l'attente d'une solution pour la souris. Je suis convaincu que la cause du problème vient de mon PC -

Bonjour @labricole59

Pour ce qui est de "nomodeset nolapic " c'est très simple, il suffit de supprimer les drivers nvidia du fichier iso et ensuite d'installer et de laisser faire avec le pilote de la distribution. Une fois la distribution installée tu peux remettre les drivers nvidia en passant par synaptic .

Pour ce qui est de la souris, je suppose que le matériel n'est pas reconnu par rapport au noyau de Mint

Ce qui serait intéressant et je rejoins @zelandonii c'est de tester avec une souris filaire et de récupérer, enfin essayer les informations de cette dernière dans un terminal avec la commande suivante

cat /proc/bus/input/devices | grep MOUSE && lsusb

Et ensuite en recopiant les infos dans le fichier /ext/X11/xorg.conf avec les droits administrateurs

Link to post

Merci Tulburite pour l'astuce de supprimer les drivers NVIDIA, on apprend et on progresse toujours en consultant les forums. :rolleyes:

Si je devais à nouveau recommencer une nouvelle installation de distribution sur ce PC, je mettrai ton astuce en

application.

Pour la souris, je vais tenter d'essayer ta solution que j'ai en l'état du mal à comprendre. ( Je ne suis pas un habitué de Linux et certains termes sont pour moi incompréhensibles ) Mais je te remercie quand même. 

Link to post
Il y a 6 heures, labricole59 a dit :

Merci Tulburite pour l'astuce de supprimer les drivers NVIDIA, on apprend et on progresse toujours en consultant les forums. :rolleyes:

Si je devais à nouveau recommencer une nouvelle installation de distribution sur ce PC, je mettrai ton astuce en

application.

Alors je suis confus :blush: mais j'ai été regarder dans le fichier ISO de Linux MInt 20.1 et je n'ai pas de drivers nvidia ..., en réfléchissant un peu avec la tête, c'est normal, car le bureau XFCE est une bureau léger en comparaison du bureau GNOME ou KDE.

Link to post

Je crois que depuis que je suis membre de ce forum, cela doit être le dépannage où j'ai répondu en premier, le plus long auquel j'ai été confronté. Et ce n'est pas fini.

  • Triste 1
Link to post

Bonjour,

Je reviens sur ce sujet avec une nouvelle discussion car j'ai constaté que le précédent ne pouvait plus recevoir de réponse.

J'ai passé beaucoup de temps à effectuer des recherches pour ce sujet, ce qui explique le retard -

J'ai trouvé une solution pour que ma souris fonctionne à nouveau.
Sauf qu'à chaque démarrage de mon PC je suis obligé d'entrer dans le grub, puis " options avancées " et ensuite je sélectionne l'avant dernière ligne :
Linux Mint 19.3 Xfce, avec Linux 5.0.0.32-generic.
Vais je devoir effectuer cette manip à chaque démarrage ? Y a t'il une solution pour éviter cette manip ?

Link to post
Il y a 7 heures, labricole59 a dit :

Bonjour,

Je reviens sur ce sujet avec une nouvelle discussion car j'ai constaté que le précédent ne pouvait plus recevoir de réponse.

J'ai passé beaucoup de temps à effectuer des recherches pour ce sujet, ce qui explique le retard -

J'ai trouvé une solution pour que ma souris fonctionne à nouveau.
Sauf qu'à chaque démarrage de mon PC je suis obligé d'entrer dans le grub, puis " options avancées " et ensuite je sélectionne l'avant dernière ligne :
Linux Mint 19.3 Xfce, avec Linux 5.0.0.32-generic.
Vais je devoir effectuer cette manip à chaque démarrage ? Y a t'il une solution pour éviter cette manip ?

Bonjour @labricole59, bonjour @zelandonii

On va déjà lister les noyaux que tu as sut ta Mint et la version courante que tu utilises, pour cela tu tapes dans un terminal cette commande

dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

Reviens avec des captures d'écran.

Edited by Tulburite
Link to post

Bonjour tulburite.

Depuis mon dernier post, j'ai réussi à effectuer une manip afin que le Grub s'affiche au démarrage.

Sinon ci-dessous en capture d'écran la liste des noyaux

 

Capture d’écran_2021-03-08_09-32-55.png

Link to post

Pour être certain de ne pas faire de connerie, tu utilises bien le noyau 5.0.0-32 pour que ta souris fonctionne ? je pense que c'est le cas. Comme tu peux le voir tu as un "vieux noyau" par rapport aux derniers en date et qu'il n'est jamais bon de tous les supprimer (il faut laisser normalement deux noyaux avec celui qui est utilisé)

Cependant on va essayer de supprimer les noyaux non utilisables avec un terminal et cette commande.

sudo apt purge linux-image-5.4.0-65-generic linux-image-unsigned-5.4.0-65-generic linux-modules-5.4.0-65-generic linux-modules-extra-5.4.0-65-generic linux-headers-5.4.0-65-generic linux-generic-hwe-18.04 linux-image-generic-hwe-18.04 linux-hwe-5.4-headers-5.4.0-65

Tu vas peut-être avoir un message d'erreur parce que c'est une commande que j'ai et que j'ai adapté en fonction de tes noyaux.

Si cette commande passe, n'oublie pas de faire ensuite

sudo update-grub

Pour terminer tu relances cette commande

dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

Et tu reviens avec une capture d'écran

 

Edited by Tulburite
Link to post
il y a 2 minutes, labricole59 a dit :

Ouf ! je n'ai pas eu de message d'erreur et ta commande est passée.

Voir ci dessous la capture d'écran :

 

Capture d’écran_2021-03-08_11-21-47.png

c'est simple maintenant tu repasses cette commande

sudo apt purge linux-image-5.4.0-66-generic linux-image-unsigned-5.4.0-66-generic linux-modules-5.4.0-66-generic linux-modules-extra-5.4.0-66-generic linux-headers-5.4.0-66-generic linux-generic-hwe-18.04 linux-image-generic-hwe-18.04 linux-hwe-5.4-headers-5.4.0-66

Une fois cette commande passée tu refais un

sudo update-grub

Ensuite tu repasses cette commande

dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

Et tu reviens avec une capture d'écran.

Comme signalé plus haut, il faudrait toujours garder 2 noyaux, nous pourrons installer par la suite un autre noyau dans la série 5.0.0-32 .... et tester si ta souris est reconnue. Par contre je suis surpris que ton ordinateur ne prenne pas en charge les nouveaux noyaux. Pour tester, j'ai installé la dernière version de Mint sur un vieux Dell et ça fonctionne très bien. As-tu fait une mise à jour du Bios commandé plus haut ?

Link to post

Re,

Je sais pas si les manips effectuées ont une relation de cause à effet, mais voilà désormais que le gestionnaire de mise à jour me demande la mise à jour vers un nouveau noyau, voir capture ci-dessous.

Faut il que je lance cette mise à jour ?

Capture d’écran_2021-03-08_11-27-31.png

Link to post
il y a 5 minutes, labricole59 a dit :

Re,

Je sais pas si les manips effectuées ont une relation de cause à effet, mais voilà désormais que le gestionnaire de mise à jour me demande la mise à jour vers un nouveau noyau, voir capture ci-dessous.

Faut il que je lance cette mise à jour ?

Capture d’écran_2021-03-08_11-27-31.png

Non tu ne fais pas cette mise à jour, on bloquera la mise à jour des noyaux avec synaptic

Edited by Tulburite
Link to post
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...