meridian-shaft Jump to content
Forums

SeaFile


Recommended Posts

Bonjour,

Je n'avais pas encore lu l'article.

J'ai un VPS avec CentOS 8.

J'ai lancé l'installation de seafile-server-7.1.5, en suivant ce lien : https://wiki.kogite.fr/index.php/Seafile_:_installation_sur_CentOS#Installation
Arrivé à la derniere étape :  ./seahub.sh start , voici ce que j'ai :
----------------------------------------
Successfully created seafile admin
----------------------------------------
Error:Seahub failed to start.
Please try to run "./seahub.sh start" again
[[email protected] seafile-server-7.1.5]# ./seahub.sh start

LC_ALL is not set in ENV, set to en_US.UTF-8
./seahub.sh: ligne 210: avertissement :setlocale : LC_ALL :  impossible de changer le paramètre de langue (en_US.UTF-8) : Aucun fichier ou dossier de ce type
./seahub.sh: ligne 210: avertissement :setlocale : LC_ALL : impossible de changer le paramètre de langue (en_US.UTF-8)
Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./seahub.sh start" again
[[email protected] seafile-server-7.1.5]#
 
 Et là je suis bloqué.
A+
Link to post
il y a 9 minutes, zelandonii a dit :

As-tu bien décommenté les  lignes nécessaires ?

Je pense que tu parles pourle fichier seahub_settings.py,  normalement oui mais sans conviction.

il y a 9 minutes, zelandonii a dit :

Est-ce que lors du chargement de Seafile, le programme trouve ton nom de domaine ?

Oui, je le retrouve même dans le fichier seahub_settings.py

Si tu regarde le tuto que j'ai suivi, je suis arrivé à :"On peut alors tester Seafile directement : "

Et c'est la 2eme ligne de commande qui donne ce que j'ai affiché au 1er post.

Link to post

Ça tombe bien, moi aussi actuellement je n'arrive plus à lancer Seafile.:biggrin:

Le problème, c'est que ton tuto est très différent de celui de Le Crabe et je ne connais pas du tout CentOS.

Edited by zelandonii
Link to post

RE

J'ai tenté l"installation sur CentOS 8.

J'ai lancé l'install des paquets mais :

Citation

Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:01 le sam. 23 janv. 2021 09:17:37 EST.
Aucune correspondance pour le paramètre: yum-transport-https
Le paquet ca-certificates-2020.2.41-80.0.el8_2.noarch est déjà installé.
Le paquet curl-7.61.1-14.el8_3.1.x86_64 est déjà installé.
Aucune correspondance pour le paramètre: gnupg-agent
Aucune correspondance pour le paramètre: software-properties-common
Erreur : Impossible de trouver une correspondance: yum-transport-https gnupg-agent software-properties-common

J'ai voulu continuer en sachant que .....

Ajoutez la clé GPG de Docker :
  curl -fsSL https://download.docker.com/linux/debian/gpg | sudo yum-key add -

Citation

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo yum-key add -
sudo: yum-key : commande introuvable
(23) Failed writing body

Voili, voilou :sad:

Link to post

RE

Sur l'autre tuto, il y a ceci :

Dans /home/seafile, éditer ccnet/ccnet.conf, modifier SERVICE_URL par l'URL externe de Seafile (ce paramètre sera utilisé pour construire notamment les liens qui pourraient être envoyés par mail) :

Citation
  

Editer seahub_settings.py, ajouter :

Citation
C'est vers le milieu :
https://wiki.kogite.fr/index.php/Seafile_:_installation_sur_CentOS#Installation
Link to post

D'accord mais on voit que ce sont deux systèmes différents car la procédure n'est pas vraiment la même.

J'ai ce problème depuis que j'ai eu une mise à jour de Docker.

Link to post

RE

Le 23/01/2021 à 20:58, zelandonii a dit :

J'ai ce problème depuis que j'ai eu une mise à jour de Docker.

Ha bon, intêressant à savoir, donc même si on réussi, c'est pas gagné.

Plutôt refroidissant d'installer SeaFile.

Link to post
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.